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If you have Scripture that is not in SFM format, you can import it into Paratext using SILAS.
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1 1. Install Silas

1. Install Silas.
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2 2. Open the File in Microsoft Word and Start
SILAS

1. Open the Word file you wish to convert
a. If you just have plain text, open the plain text in Word and save it as a DOC/DOCX. Silas must
have a DOC/DOCX to work with.
2. Click on Add-Ins > Attach SILAS Formatting Template

Home Insert Page Layout References Mailings Reutaw View Developer Add-Ing
E[E Data Conversion ) JumpZTaolbox F12 gﬁ
¥ Consistent Spelling @mam SILAS Formatting Template Convert selection Regexfind/replace Check round-trip comversion Reset

I Apply Speling Corrections
Menu Commands Custom Toolbars

3. If the following window comes up, you can click Cancel unless you want to specify settings for a
specific language to import. If you define settings, you may avoid some of the "extra" windows that

come up (see Window Pop-Ups below)
Language Project Information Farm g—l

Thasa are the Bnguage project sattings for your cumant Scriptura portion,

You must put a name into the “Language/Project Name™ box (you can't leave i blnk); but f you are nok sure what to fill inko
any af the athir boxes, you rmay leade them bhnk or ke the entries that are already there far naw.

Language)| Kokmeves P sl = G
Project Nam!llll
E‘mﬂtl S Praject Code
':w'fl Ta.rpa:buaderswll'm'e two components:

1. Book Mame and ourent dhapter(s) on each page,

Please answer the following guesbions about formatting your primtouts: For exmyer Mistie 34

I 1. Page Mumber
What font will youuse? | Times Mesw Roman j =
. Which component goes at the Outside margin?
= Headng fonit and % Page Mumber
Be aware that typeset Soiptures nomsally Lse Adyanced Fant Options ™ Bock Mame and chapter(s)
% or 10 point for double column, {ioptonal) o

10 or 11 paint for single column,

Where dos=s the other P
Replace angle brackets (< <and > >} with curly quotes in proof prinkouts? = e

7 [nside
" = Mo i i
= " Centered i Header

Farmat chapber nusmbsens as Drop Cap numbens?
¥ Yes ™ Hade numbaer for verse 1 in each chapter
™ Mo Moite: DrapCaps will be reated when vou nun a formatiting job,

- gither 1, Format for Proof Printouts

o 2. Format for Half-Page Booklets
[ etake hyphens (-) non-breaking in Proof printouts [ Change hyohers (-) o thin spaces in Booklels
I™ Make Brackets { and ) half stze to show implied information [~ Restart footnote references at ‘s’ each page

Chck "0 to use this project; or "Cancel” to quit withowt making changes;
or "Add a5 New" to add a new Enguage project to the kst of avalable projects.

| (= 4 | Canced Add as hew Language Project
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4. You can also ignore the following comment as well. Just press OK to continue.

Microsoft Word [ S|

It looks as if the settings for "Koluwawa" Language Project has nothing in the
"Country" setting box. Please open the "Scrlanguages” menu and do the job
called "Change 5ettings For A Language Project."
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3 3. Use SILAS

From here, you can do a few different things:

3.1 Try "Save as USFM Scripture"”

1. Go tothe Add-Ins tab > Save as USFM Scripture

4/ Home Insert Page Layout References Mailings Review Wiew Deweloper Add-lms
Sdripture - Vi Sawe A5 USFM Scipture ¥ Apply Spelng Corrections WE
SorLanguages - :I‘_‘ Diata Carwersion L] JumplToolbox F12  Convert selection Reges find/replace Check round-trp cormversion Fesed
WISFM 1o Styles = 3 Consistent Spalling T B R R
bearu Command Custom Toalbar

2. If that doesn't work (i.e., if verse numbers do NOT get converted properly try the following), try the
next things.

3.2 Format Styles

1. If you have the ability to "Select All Text With Similar Formatting” (I know Office 2003 and up has it)
and your verse humbers and/or section headings have specific styles, do the following for each style
type (e.g., chapter, verse, section heading)

a. Select some text with the specified style.
b. Click Select All Text with Similar Formatting
i. Office 2007/2010: Right-click > Styles > Select All Text with Similar Formatting
ii. Office 2003: Right-click > Select All Text with Similar Formatting
c. Open the Styles window (CTRL + SHIFT + S)
i. Office 2007/2010: This will open the Task Pane
ii. Office 2003: This will highlight the Style area in the task bar
d. Choose the appropriate style (all start with the corresponding backslash code in Paratext)
i. v-Verse Number
ii. ¢- Chapter Number
iii. s-Section Heading
1. Click ENTER or the Apply/Reapply button
e. Repeat for each style type.
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3.3 Format Verse Numbers

1. Click on USFM to Styles > Format Verse Numbers. This will automatically cycle through the
document and check all numbers to see if they should be verse numbers. It will ask you to verify if

"out-of-sequence" numbers are actual verse numbers or just part of the text.

Cla
o Home Insert Page Layout References
scripture - \id save As USFM Scripture 3% Apply Spelli
Scrlanguages - a% Data Conwversion Wy Jump2Toolb

| LISFM to Styles =| o Consistent Spelling

L=l =

Delete Text From File Based on the Template

Change At characters to Quotes

Fix backslash Codes

USFM to Styles

Join Selected Paragraphs and reduce multiple spaces
Reduce Multiple Spaces to 1 each

Format Verse Numbers

Change Tildes To Fixed Spaces
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4 4. Save and Edit SFM File

Once your Word document is as far as you can get it:

1. Gotothe Add-Ins tab > Save as USFM Scripture.
2. Once the "Save as USFM Scripture" has processed, | recommend:
a. Adding the \id line to the beginning of the document:
i. See Paratext Book Names and Abbreviations.
b. Saving the created TXT file.
c. Closing that TXT file in Word
d. Opening itin a good text editor for further processing
i. I highly recommend EditPad Lite (it's free).

3. Sometimes Silas works wonderfully and you don't have to make any changes. Other times, it will put
\Chapter instead of \c, or \quote/poetry instead of \q1, etc. | use EditPad Lite to find/replace these

changes so they work for Paratext.

a. If you know about doing regex replacement, that can be very helpful to process some of the
changes that may need to be made (EditPad Lite has great regex functionality). If not, that's

ok, it will just take you a little while longer. =
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5 5. Import into Paratext

After you have all of the changes you want, import it into Paratext. This can be done in 1 of 2 ways.

Note: It can be VERY helpful to create a temporary project where you can fix everything up, then copy the
files to the "real" project. This avoids cluttering the real project's history).

5.1 Import Books

1. Project > Import Books

5.2 Copy/Paste

Copy all of the text of the TXT file

In Paratext (under the project/book you're importing into), uncheck View > By Chapter
Choose View > Standard

Paste the contents of the TXT file

DR
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6 6. Fix Backslash Codes using Regex

MUCH of the work of converting to SFM is done for you by SILAS because it creates virtually all of the
backslash codes you need, but there are often invalid backslash codes generated (either remnant from the
SILAS export, or from the original data).

You can fix the errors in a number of ways. See Helpful Regex Expressions below for help with regex.

Be sure to use Mark Point in Project History frequently in case you make a mistake.

6.1 Paratext

1. Run Chapter/Verse Numbers and Markers checks
a. This can also help identify errors to fix using RegExPal or EditPad Lite.
2. Do afind/replace for simple code changes
3. View > Standard can be helpful for this because it will highlight errors in backslash codes in red.

6.2 RegExPal

This can help fine-tune your regex and keep a history of what has happened in the case of an error

1. Use the Extract feature before applying the replace to make sure you're finding exactly what you want
2. Use the Replace feature to make the changes you want
3. Close/Re-open the project in Paratext to view changes

6.3 Use EditPad Lite

This is especially useful if there are empty paragraph markers at the end of a chapter

1. Editin EditPad Lite
2. Re-import.
3. Use Mark Point in Project History because EditPad Lite does NOT keep track of history.
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7 Helpful Regex Expressions

7.1 Remove empty \p markers at the end of a chapter

(EditPad Lite)

RegExPal can't really be used to find empty \p markers are the end of a chapter because it keeps chapters

separate.

You can do the following in EditPad Lite though:

® Find: \\p\r\n\\c
®* Replace: \c

7.2 Add missing \p after \s

® Find: (\s[ 123].9\r\n)(\\v)
® Replace: \1\p\r\n\2

7.3 Remove extra\p

® Find: (\p ®\r\n)+\p
® Replace: \\p

7.4 Add \p between \c and \v

* Find: (\c [0-9]+\r\n)(\\v)
® Replace: \1\p\r\n\2

7.5 Remove empty \p before \s

® Find: \p ®\r\n(\\s[ 123])
® Replace: \1

7.5.1 Find Chapter/Verse Numbers at the End of a Line

* TODO
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8 Helpful Tips

8.1 Adding Missing References to Footnotes and
Cross-References

Paratext makes it simple to add missing references to footnotes and cross-references

1. Use Checking > Paratext 6 Checks > Publishing > Insert Footnote References.
2. Be sure to click Options and make the following changes
a. CV Separator: put a ":" instead of "." if you wish
b. Insert \fr: Choose "Yes" to insert references in a footnote (default is "No")
c. Insert \xo: Choose "Yes" to insert references in a cross reference

3. Note: Before running this, make sure each footnote\cross reference has at least "\f + \ft ..." or "\x -

\xt..." or the reference will be inserted after the first word. For example

a. Without Ift
i. Start: \f This is a footnote\f{*}
ii. End:\f This \fr 1:2 \fr is a footnote\f*{*}

b. With \ft
i. START: \f +\ft This is a footnote*
ii. END:\f +\fr 1:2 \fr This is a footnote{*}

4. After running this, you will need to replace \fr* with \ft.

8.2 Refresh the Project in Paratext

If using RegExPal and Basic Checks in Paratext, you can do the following to refresh the project in Paratext

1. Make changes in RegExPal

2. Close the project in Paratext
3. Press "Rerun" in the checking window: this will re-open the project window as well
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9 Window Pop-Ups

There are number of other possible windows that can come up (and may or may not be consistent) which
can be ignored if you want. They are listed below:

9.1 No Language Set (LLD)

Mo Language Set (LLD) | |

I."'_"“-.I The template has been attached, but your text does not have
‘S astandard USFM ID line. You should choose the language project you
want to use for this text.

If you would like to do this now, click "Yes'.

1. This means there is no\id line:
a. | find it easier to add it later so you can click "No".
b. If you want to define a language, click "Yes".

9.2 Style names from out-of-date stylesheet

Style names from out-of-date stylesheet ||

By the way, the stylesheet used to make this file is a bit out-of-date.
some functions of the Silas package might not weark,

Please tell your support person and ask about using
the latest version of the stylesheet, USFM.sty or USFM_draft.sty.

The details are in the file
CAMy Paratext Projects\Languages.ini
in the section called [Messages).

1. Click OK
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9.3 No Language Set (SetDefPaperSize)

Mo Language Set (SetDefPaperSize) i

You must first assign a language to this Scripture text file. To do this, please open

the "Scrlanguages” menu and do the job called "Set Language Project For This
Ta‘tlll

1. Thisisn't necessary, just click OK

9.4 If your current file is NOT a Scripture portion...

Microsoft Word ]

If your current file is NOT a Scripture portion exported from Paratext 6 or later,
you may attach the Silas template anyway.

(Some features won't work properly, because of different style names.)
Do you wish to do so now?

If you choose "MO" or "CAMNCEL" here, the ternplate will not be attached.

Cancel

1. Click Yes because you WANT to attach the template anyway.
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9.5 | can't find the standard USFM stylenames in your
document.

Silas -- Smart Interactive Layout Assistant for Scripture )

I can't find the standard USFM stylenames in your document.
Perhaps you didn't run the setup program to install "Silas" —

Smart Interactive Layout Assistant for Scnpture.

When you do that, it will copy the latest version of "USFM.sty’

to your Paratext settings folder ('C:\My Paratext Projects’ by default).

Then make sure that USFM.STY is set as the 'stylesheet’ for your
Paratext Scripture project:

In Paratext, do Tools—>Project Properties and Settings,
then look at the Stylesheet bow.  you make a change here,
you will need to close the Paratext program and then

run it again to get the stylesheet working.

1. Click OK and see if it works.
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