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| Summary/Background

Having access to a well formed dictionary in the target language can be a great help in drafting and
checking a translation. If the dictionary has thesaurus information with synonyms, antonyms, and related
words linked through shared semantic domains, it could be used to help translators access the full
richness of their language and make a more vivid translation. Further, if the dictionary could be in
electronic form and be accessible while working in Paratext, it would be both fast and convenient for
translators to use.

SIL has already developed software to make this type of electronic dictionary with semantic domains. It is
called FLEx which is part of a bigger software program called FieldWorks. FLEx can also do complex
morphological analysis and discourse analysis, but this document will focus mostly on its lexigraphic
capabilities.

Paratext and FLEx have been modified to allow Paratext to access a dictionary in FLEx in some ways that
can be very helpful to translators.

e Find the definition of words with a right-click
o Matches based on glosses
o Can separate affixes from inflected forms to find stems in dictionary (using word analysis from
FLEx)
o If no word is found, provides means to add the word to the dictionary
e Find words related to a word in a Paratext project with a right-click
o Generates a list based on glosses, shared semantic domains, defined lexical relations

These Find in Dictionary and Related Words functions can be accessed from the main editing window,
inside the Wordlist Tool, and while working with the Biblical Terms Tool.

While working on a translation in Paratext these functions depend on a dictionary of the target language
being available. If you don’t have one, maybe other linguists have one that they could make available. If
the dictionary is in an older format such as ToolBox or LinguaLinks, contact a Language Technology
Specialist to help you convert the data. If no dictionary can be found, consider starting a dictionary
project to support your translation. One good method is the Rapid Word Collection method.

(http://www sil.org/dictionaries-lexicography/rapid-word-collection-methodology) There are other
standardized wordlists that can used as a basis for building a lexicon. There is the Central Africa Wordlist
(CAWL) which is about 1,700 words long, and the Multi-lingual Education (MLE) 4000 wordlist.
(http://lingtran.net/resources?structure=Navmenu) And as has been mentioned you can build a dictionary
right from inside Paratext, but you would have to create a blank FLEx lexicon to copy the words into.

How+to+associate+a+FLEx+project+with+a+Paratext+project

Once a Paratext project is linked or “associated” with a FLEx project it is easy to import the Paratext data
into FLEx for doing sophisticated linguistic analysis. Morphological analysis can be used to resolve
grammatical and spelling issues in the translation. Discourse analysis can be done to increase naturalness
and reading comprehension of the translation. This type of analysis will be most beneficial if other natural
texts have already been analyzed in FLEx, and FLEx has already been taught the basics of the grammar of
the target language.
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[l Uninflected words
A) Example of finding the definition of a word while editing a translation
Files needed:

“PTE2015” Paratext project (Vernacular translation)“Beginner’s English” FLEx database (small lexicon
with semantic domains and some Lexical relations)

Last
Last modified

ID Filename Name Description Size modified by
898 Beginner&#039;s  Beginner&#039;s 2.02&nbsp;MB  2015-11-03

English English 2015 09

2015-09-04 1121 04 1121 Start Of

Start of Integration Guide

Integration

Guide.fwbackup

Last
Last modified

ID Filename Name Description Size modified by

899 PTE2015 PTE2015 474.97&nbsp;KB  2015-11-03
2015-09-04.zip 2015-09-04.zip

Procedure:

e Download files,
o restore PTE2015 into Paratext (File > Restore Project > From File)
o restore "Beginners English" into FLEx, (Choose Restore a project from a backup file from the
project picker dialog, or File > Project Management > Restore a Project).
e Open the “PTE2015” Paratext project, and navigate to Matthew 5:22
e Click on the word “angry” then right-click. This will open a pop up window.
e Click on Find in Dictionary. (If Find in Dictionary fails after you've just restored the projects, try
shutting down FLEx and Paratext and restarting them.
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English”.
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B) Example of finding related words while editing a translation
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Procedure:

e Highlight or click on the word “angry” then right-click. This will open a pop up window.
e Click on Find Related Words.

Another pop up window will open with a list of words with similar glosses and words that share semantic
domains with “angry” from the FLEx dictionary Beginner’s English. The translation team can evaluate
if any of the words on the list would be better suited for the context of Matthew 5:22.
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[l Inflected words
A) Example of finding the definition of an inflected word
Files needed:

“TKE_GaA” Paratext project (Vernacular translation)“BT1” Paratext project (Back translation)Takwane




Thematic Dictionary FLEx database (Partial lexicon with semantic domains and some Lexical relations)

Last
Last modified
ID Filename Name Description Size modified by
958 TKE GaA TKE GaA 385.39&nbsp;KB  2015-11-11
2015-11-11.zip 2015-11-11.zip
Last
Last modified
ID Filename Name Description Size modified by
901 Takwane Thematic Dictionary Takwane 12.36&nbsp;MB  2015-11-03
2015-09-04 1510 Thematic
Paratext Integration DemoStart.fwbac Dictionary

2015 09 04

1510

Paratext

Integration

DemoStart

Last
Last modified

ID Filename Name Description Size modified by
903 BT1 BT1 117.96&nbsp; KB 2015-11-03

2015-11-03.zip 2015-11-03.zip

Procedure:

e Download files,

e restore TKE_GaA and BT1 into Paratext (File > Restore Project > From File)

e restore "Takwane Thematic Dictionary" into FLEx, (Choose Restore a project from a backup file from
the project picker dialog, or File > Project Management > Restore a Project).

e In TKE GaA go to Mark 14:30

e Highlight "ogikoodda"

e Right-click and select Find in Dictionary. If Find in Dictionary fails right after restoring the
projects, try restarting FLEx and Paratext.

This is an inflected form and the search will not find it. If you know the morphology of the language
deleting affixes manually can help Find in Dictionary function to find the stem in the FLEx lexicon.
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e Delete the prefix "ogi" and the lookup will find the stem "koodda" which means "deny" or "reject".
e Click on the Go to button. This will show the full definition in all the languages in the database. In
this case, you will see English and Portuguese, but you could build a lexicon with whatever other

language of wider communication (LWC) that is used in your area.

If you wanted to see the full entry in FLEx or to see the words contiguous with "koodda" you could click
on the Open Lexicon button and it would open FLEx.

I gﬂ}”." vano I J Ahihiirawa wnano rﬂLLn':'FlJ
Dicticnary Entry na
¢ _ .
| *koodda 1)v deny; refuse to do something; "
not accept that something is true 2)v reject

—]

| Open Lexicon Close

sheep will be 11 e ™t vano awelagaw

e Click on Close and close the current lookup window.

B) Example of Finding Related Words
Procedure:

e In Paratext go to Mark 1:28.
e Right-click on "Bili" (which means fame).
¢ Click on Find Related Words.

It will return the Related Words pop up window that will show all words that have the same semantic
domains as "bili" and any words that have been linked to “bili” as having a lexical relation with it. Lexical
relations includes such things as antonym, synonym, part-whole and so forth. Notice that in this example
the Related Word function found four synonyms for "bili".
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if you are able to edit the cument tesd, you can select the best choice for the cument

IV Adding New Words to FLEx Dictionary

When you encounter a word that is not in the FLEx dictionary it can be added to FLEx. This is a way to
grow a dictionary as you are translating. The method of adding words to the FLEx dictionary from within
Paratext only enters the lexeme and the gloss in the primary analysis language. It does not allow for
entering a full definition, part of speech or a gloss in other analysis language(s). If you wish to enter any
additional information, you must either do that at a later time, or stop and open FLEx and fill in all the
additional information that you wish to enter.
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Now we will find a word in our Paratext project that is not currently in our FLEx dictionary and we will
enter that word and its gloss into FLEx. Start Paratext if it is not open already, and open the project

TKE GaA. Navigate to Mark 1:16. Find the word “vowi” and highlight it. Right-click on “vowi” and select
Find in dictionary. You should see a popup like this one:

We can see from the blank box under Headword that no match was found. Paratext will find a match if it
finds the headword or any of its allomorphs that have been entered into FLEx for that headword--.--
Paratext will not find a match if this is new word or allomorph. As of right now Paratext does not search
the variant fields in FLEx, so it will not match any spelling, dialect, or irregularly inflected variants that
have been entered into FLEx.

To create a new entry in the FLEx dictionary, click on the “create” at the bottom of the popup window.
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Type the English gloss for the “vowi” which is “for”. When you have finished typing in the gloss, click on
the “create” button, an entry for “vowi” will be created in FLEx, and the pop up window will close.

| "4 New Entry >
Lexeme Form )
VOWwI
II \
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fnd ]
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it Create Cancel

Now we can go back to Mark 1:16 and lookup the definition of “vowi” and it will be there. Navigate to
Mark 1:16, highlight “vowi” and right-click on it. Select “Find in dictionary” and now we will see the
gloss of “vowi”.
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We can open the FLEx dictionary and confirm that “vowi” has been added and do any editing that we
want to do to that entry. Click on the “Open Lexicon” button. FLEx will open and display the entry for
“vowi”. We could add grammatical information, full definitions, an example sentence or anything else we
would wish to have in our dictionary.
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| Show All v | Show Al v
*volosiha volosih

*volowa volow

*vonya vony

*voreya vorey

votibeya votibeya

vowl vowi

*vudda vudd
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V Finding a word in the dictionary when Spell Check is turned on

When spell check is turned on (there are red squiggle underlines), then you cannot use the Find in
Dictionary or Find related Words function by using a right-click on any words that are underlined by
the spell checker. When you right-click on a word underlined by the spell checker, the spell checker
opens. To get around this problem there is a keyboard shortcut that allows you to use the Find in
Dictionary function on underlined words. The short cut key is ctrl+d. You may want to look up a word in
the FLEx dictionary even if Paratext does not know if the word is spelled correctly or not, because it may
already be in the FLEx dictionary with an approved spelling from some other source such as traditional
stories that have been collected or other methods of building a dictionary such as the “Rapid Word
Collection” method.

We will demonstrate this in action. Open the Paratext project TKE GaA, and navigate once again to Mark
1:16. Click on the spell check tool on the toolbar. Some of the words in Mark should become underlined.

4 Paratext 7.6

File Edit View Inset Tools Project Checking Window  Help
[ = | A = TKE GahA - Gospe - |MF{K v| |1 |1 4 |13 |' *|| p - Paragraph - Normal - B a4 e“l"isf‘ 8 | : ¥ &
|4 (A) TKE_GaA MRK 1:18 (Jeff Shrum, Alan Yam) 3= | a2 BT MR
T & % &~ 46 Mot Finished T & & .
r (Matewuzhi 4.18-22; LUka 5.1-171) ~ | [ormmoTTart
\e %[ ] Yesu eeddaga seresere ya Nyaza ya oGalileya, ahawoonaga addibila abiili, Simawu (net)fishe
ni Andire, evokedhaga mathavi munyaza, vowi yaali anamatota. * 7 [ ] Vano Yesu fisherme:
ahawaaddelaga, wiira: <<Mudhe mugiharege, guwiireni anamatota a athu>>. » &[] followed |

Mowaaguva aliwa yahaahiyaga mathavi e|ewa, omuharaga. * *° [ | Egeeddile vang'ono, Yesu

ahawoonaga addibila amohi abiili. Tiyago ni ddibile Zhuwawu, ahima a Zebedeyo. Egali people. T!
mmwanddeyani ni babiiwa esasanyedhaga mathavi eewa. » 2°[ | Mowaaguva Yesu WETE prej

ahawiithanaga. Aliwa yahimwihiyaga babiiwa Zebedeyo ni anamalaba aaye mmwanddeyani, left their:
omuharaga Yesu.

\s1 Yesu onowiigara muneba wootakala mwa mulobwana oKafaranawu
- (Luka 4.31-37)

w2l

e * 21 [ ] Aliwa yahidhowaga oKafaranawu. Vano nigafiyile nlabo na sabuddu, Yesu P [
ahivolowaga mu nyuba ya matugumano,f wambeela osuuziha. * 22 [ ] Athu yootikinaga entered i1
dhosuuziha dhaaye, mwaha oosuuzihaga ni othongi, ochiyanihaga ni masuuzihelo a his teachi

T ararm

Place your cursor inside of the word “anamatota” in Mark 1:16. Press Ctrl+d. It will invoke the Find in



Dictionary function and return the gloss from the FLEx dictionary.

4 () TKE_GaA MRK 1:16 (Jeff Shrum, Alan Yam) (=] | B4

T 4 % - 46 Mot Finished T

r(Matewuzhr 4.15-22; Luka 5.1-11) A
e *18[ ] Yesu eeddaga seresere ya Nyaza ya oGalileya, ahawoonaga addibila abiili, Simawu
ni Andire, evokedhaga mathavi munyaza, vowi yaali Eljecens. « 17 [ ] Vano Yesu \p
ahawaaddelaga, wiira: <<Mudhe mugiharege, guwiireni gnamatota a athu=>. » 12 [ ] Sin
Mowaaguva aliwa yahaahiyaga mathavi eewa, omuharaga. * '* [ ]| Egeeddile vang'ono, Yesu (ne
ahawoonaga addibila amaohi abiili. Tiyago ni ddihile Zhuwawu. ahima a Zehedevno. Faali .
mmwanddeyani ni babiiwa esasanyedhac Dictionary Entry n fist
ahawiithanaga. Aliwa yahimwihiyaga bab : foll
~== anamatota fishermen

omuharaga Yesu. pec
\s1 Yesu onowiigara muneba we.
left

W
e * 21 [ ] Aliwa yahidhowaga oKafarane ool Close

ahivolowaga mu nyuba ya matugumano,” wambeela osuuziha. “<|_| Athu yootkinaga
dhosuuziha dhaaye, mwaha oosuuzihaga ni othongi, oohiyanihaga ni masuuzihelo a

(Note: There is no similar keyboard shortcut to invoke the Related Words function while the spell

checker is activated.)

VI Adding a word to the dictionary when Spell Check is turned on

It is also possible to add a new word to the FLEx dictionary while ParaTExt’s spell checker is enabled. We
will add the word “vang'ono” from Mark 1:19 to the FLEx dictionary. Navigate to Mark 1:19. Turn on

spell check if it is not still on. Place the cursor in the middle of “vang'ono”. Press Crtl+d.



4 (A) TKE_Gah MRK 1:19
3 4 ﬂ'b v - 46 Mot Fil

Andire, evokedhaga mathavi munyaza, vowi yaali anamatota. 7 [ | Vano Yesu
ahawaaddelaga, wiira: <<Mudhe mugiharege, guwiireni anamatota a athu>>. 18]
Mowaaguva aliwa yahaahiyaga mathavi eewa, omuharaga. **[ ] Egeeddile , Yesu
ahawoonaga addibila amohi abiili. leago ni ddi I:ule Zhuwawu ahima a Zehedexo Egall
mmwanddeyani ni babiiwa ¢ me e

ahawiithanaga. Aliwa yahim & Find in Dictionary X ani,
omuharaga Yesu. Find: vang'ono S 9
Yesu onowiigars;
Headword Allomorphs Glosszes LS
21 [ ] Aliwa yahidhowaga | vaga
mu nyuba ya matugumano aaye,
mwaha oosuuzihaga ni oth llo.
23[ ] Mu nyuba ya matug
wootakala. Ahikuwaaa ni nc
* 1.1 Kirixtu mu ewogelo y whiwa
ulugu, oyene onaavulumu
1.2 Malakiya 3.1.
li1 .3 Ezaya 40.3 (Bibiliya S
1.6 Namavuhulela Ellya2|\ . hda
dhinatoonya wi Zhuwawu a
1.11 Moone Wambeela 2. Create Cancel
1.21 Nyuba dha matugu.._. e e e e __)AS53

eewa kavaali oclohelamﬂoue naar osuuzamo Malamulo, mbwenye teto yowaathongamo at
1}.«*ahaaharli'larr'n] Malamulo a aZhudewu.

e Click on the Create button on the bottom of the pop up window.
e Type in the gloss “small”. Then click on Create button. The pop up window will close and there will
now be an entry in FLEx dictionary for “vang'ono”.



P4 (4) TKE_GaA MRK 1:19
T4 % - 46 No
Andire, evokedhaga mathavi munyaza, vowi yaali anamatota. ** | | Vano Yesu
ahawaaddelaga, wiira: <<Mudhe mugiharege, guwiireni anamatota a athu=>. 8[|
Mowaaguva aliwa yahaahiyaga mathavi eewa, omuharaga. **[ | Egeeddile , Yesu

ahawoonaga addibila amohi abiili. Tiyago ni ddibile Zhuwawu, ahima a Zebedeyo. Egali
mmwanddeyani ni babiiwa esasanyedhaga mathavi eewa. 2°[ | Mowaaguva Yesu

ahawiithanaga. Aliwa yahimwihiyaga babiiwa Zebedeyo ni anamalaba aaye mmwanddeyani
omuharaga Yesu.

Yesu W "4 Mew Entry >
Lexeme Form '

21 1] Aliwa yahidhow: vangono lowac
mu nyuba ya matugum dhaay
mwaha oosuuzihaga ni &' small Engiish ¥ mulo.

23] Mu nyuba ya m:
wootakala. Ahikuwaaa 251
a Create Cancel

1.1 Kirixtu mu ewogr ~ ) _ o sakuli

ulugu, oyene onaavulumuse athu.
_ 1.2 Malakiya 3.1.

VIl Using Find in Dictionary and Related Words from within the Wordlist tool.

The Find in Dictionary and Related words functions are accessible from within the wordlist tool.
Sometimes you may be working in the wordlist tool and you want to know what a word means, or add a
word to the FLEx dictionary. It is not necessary to close the wordlist tool to work with the FLEx

dictionary.

In the following example we will be using a word that has a spelling status of “correct” in Paratext.

e Open the TKE GaA project navigate to Mark 1:16.
e Place the cursor inside of the word “seresere” and right-click. Select Word List....



= e

I':/i Paratext 7.6

File Edit Wiew Insert Tools

5 I | A - TKEGaA -Gospe - |MRK v/ |1

Project

Checking  Window

Help

o] [16_[d]/|  ca

-

E‘. (A) TEKE_Ga& MRBE 1:16
T 4 % -

evokedhaga mathavi muny
<<Mudhe mugiharege, guv
eewa, omuharaga. **[ | E
Zhuwawu, ahima a Zebede

16[ ] Yesu eeddaga Eai=2-

dhinatoonya wi Zhuwawu 2
1.11 Moone Wambeela 2
1.21 Nyuba dha matugi

kayaali oolobelamoove, na

zahaaharihamc Malamulo :
1.24 Mu ewogelo ya eGe
1.40 Maredda mu ewog
hivana dha nikupa na muth
"1.40 Oaeeliha Naari wi: |

r Pd ra

(Matewuzhi 4.18-22; luka 5.1-11)

=% = = = = e = =
Insert Mote... Ctrl+Shift+ M
Wordlist...
Spelling...
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V

Find in Dicticnary...
Find Related Words...
View Biblical Terms
View History for Verse(s)
Guess Translations...

Mark Selected Verse As Finished

awoonaga addibila abiili, Sin

| Vano Yesu ahawaaddelz
| Mowaaguva aliwa yaha
naga addibila amohi abiili.
wa esasanyedhaga math

i 11.22; Zakariya 13.4.

7.

rego dheeriwa sinagoga.
ye teto yowaathongamo

ye mmurenddeleni.
idave mbwenye teto dhir

YT RARL A48 Ao Tl oo o2

After opening the wordlist tool “seresere” should be displayed in the middle of the wordlist.



24 Word list: TKE_GaA | b
File Edit View Tools F. 3
Allwords - | All Books - Find Word - |Filter Text
7 |word # Hyphenation Spelling Count A
Semeyini Se=meyi=ni 1 ][ %] 1
Semu Se=mu ? 7 ? 1
sentaavu sen=taa=wvu ? ? ? 2
Seputuwazhinta Se=pu=tu=waz=hin=ta i ? i 3
seresere se=re=se=re ? 7 ? 35
Serizhiyu Se=riz=hiyu ? ? ? 1
Serugi Se=ru=gi i ? i 2
Seti Se=ti 12]|v|[x%] 1
Seva Se=va I Z z 1
sevada se=va=da I z z 2
Sezareya Se=za=reya ? 7 ? 2
Sezari Se=za=ri i ? i a2
Dl ol ab an ¥

MAT 4:13 oKafaranawu, oli waaddamela seresere ya nyaza, mmigaano dha
MAT 4:18 \v 18 Yesu eeddaga seresere ya Nyaza ya oGalileya

MAT 13:1 ahivenyaga vaade, okaraati seresere ya nyaza.

MAT 13:4 bewu dhimohi dhahimorelaga seresere ya dila, balame dhahidhaaga
MAT 13:19 eli wona bewu yamorelege seresere ya dila. Nambure\f + \fr

MAT 15:29 agamaruwe vevale, agelege seresere ya Nyaza ya oGalileya, ogwela
MAT 20:30 abiii oohoona yakaraatilege seresere ya rampa, egeewile wi Yesu
MRK 1:16 \v 16 Yesu eeddaga seresere ya Nyaza ya oGalileya,

MRK 2:13 dila emohiwa odhowa seresere ya nyaza. Athu ajinjeene

MRK 4:1 osuuziha dila emohi seresere ya Nyaza ya oGalileya.

MRK 4:1  waaligi mwinko waaddamela seresere ya nyaza waaligi athu aatene.
MRK 5:21 anamwinji yahitugumanaga seresere ya nyaza vevo vaaligi oliye.

Use the Wordlist tool ta review speling, hyphenation and morphology of the words in your text.

More help...

12674 of 12674 Words (0 valid, 2 invalid, 12672 unknown)
——————— 1

A) Example of Finding in Dictionary in Biblical Terms Tool

An—

The Find in Dictionary and Related Word functions can be found in the Edit menu or you can use the

shortcut key Crtl+d for Find in Dictionary.
Procedure:

e Click on Edit
e Click on Find in Dictionary.



[Z4 Word list: TKE_Gah

File | Edit | View Tools
Set Spelling Status - Correct Ctrl+Y ]
All wor g _ J ~ | Find Word ~ |Filter Text
Set Spelling Status - Incorrect Ctrl+N
7 |W : _ : Hyphenation Spelling
- Set Spelling Status - Undecided  Ctrl+U Se—ta—=| 7 X
Approve Word Hyphenation Ctrl+A
£ Edit Word Hyphenation  Ctrl+Shift+A Se=ku=ndu || X
S Approve Word Morphology Ctrl+M Se=la || ¥
= Copy Ctrl+C se=lu o || R
< Copy References to Clipboard Se=meyi=ni ||
Copy References to List Window
s i Se=mu || %
Find... Ctrl+F
s sen=taa=vu || 9
Replace... Ctrl+H
Se=pu=tu=waz=hin=ta || 8
l Find in Dicticnary.. D | P
5 Find Related Words... I SESIESIESTE || %
Serizhiyu Se=riz=hiyu ||
Serugi Se=ru=qgi || R
Seti Se=tj || 8
MAT 4:13 oKafaranawu, oli waaddamela seresere ya nyaza, mmigaano dha
MAT 4:18 \v 18 Yesu eeddaga seresere ya Nyaza ya oGalileya

A pop up will give the glosses for all senses of “seresere”. In this case, we can see that “seresere” has

two senses.
Ed Word list: TKE_Gah
File Edit View Tools

All words ~ | All Books ~  Find Word - |Filter Text

7 |Word ¥ Hyphenation spelling
seenyu seen=yu o || |
seerile see=ri=le || 8
Sefasi Se=fa=si || K
Sekundu Se=ku=ndu || R
Sela Se=la || R
selu se=u ||
Semeyini Se=meyi=ni || 8
Semu Se=mu || K
sentaavu Dictionary Entry n <%
Seputuwazhinta seresere 1)n shore of lake, ocean or other ||
seresere large body of water 2)n river bank E;
Serizhiyu || %

MAT 4:13 oKafaranawu, oli waaddamela Other Open Lexicon Close

MAT 4:18 \v 18 Yesu eeddaga seresere ya Nyaza ya oGalileya

MAT 13:1 ahivenyaga vaade, okaraati seresere ya nyaza.




B) Example of finding Related Words in Biblical Terms Tool
Now let’s try the Related Word function. There is no keyboard shortcut for this function.

Procedure:
e Click on the Edit menu, then choose Related Word.

A pop up will appear with any words with the same gloss as “seresere” which in this case is none, and it
will list any words that share a semantic domain with “seresere”.

7
File Edit View Tools

All words + | All Books ~ Find Word » |Filter Text
? | Word ¥ Hyphenation
.‘_IL\_.II'I..I .JL.L_.II_,U
seerile see=ri=le
Sefasi Co=fa=ci
~ Find Related Words I
Sekundu n
Sela No words have the same gloss as seresere
selu
Semeyini _ :
Words related by semantic domain to Seresere:
Semu
1.2.1 -Land: muva, Takwani
sentaavu

 1.3.1 - Bodies of water: ihinje, mahinje, rugw, wiko
Seputuwazhinta 1.3.1.1 - Ocean, lake: nthiya, nyaza

' 1.3.1.3 -River: ihinje, kolopa, mahinje, njiji, wiiko
1.3.1.5 - Island, shore: ihinje, mahinje, njiji, wiiko B

seresere

Serizhiyu

MAT 4:13 oKafaranawu, oli waaddam

MAT 4:18 \v 18 Yesu eeddaga seres:

MAT 13:1  ahivenyaga vaade, okaraat

MAT 13:4 bewu dhimohi dhahimorela

MAT 13:19 eli wona bewu yamorelege

MAT 15:29 agamaruwe vevale, ageleg

MAT 20:30 abilli oohoona yakaraatilege

MRK 1:16 \v 16 Yesu eeddaga seres: [ Close |
MRK 2:13 dila emohiwa odhowa sere -
MRK 4:1 osuuziha dila emohi seresere ya Nyaza ya oGalilleya.

VIl Power from added Prefixes and Suffixes in FLEx dictionary.

If you have a word form analysis of a word in FLEX then the Find in Dictionary function will be able to
find the stem and affixes of an inflected word form. For example in project TKE_GaA in Mark 1:16 the

I



word “mathavi” is plural and means “nets”. If we try and find “mathavi” in the dictionary it cannot find
it.

Fa

4 (1) TKE_GaA MRK 1:16

T 48 V- 46 Nc
[Matewuzhi 4.18-22; Luka 5.1-11)

16[ ] Yesu eeddaga seresere ya Nyaza ya oGalileya, ahawoonaga addibila abiili, Simawu r

Andire, evokedhaga munyaza, vowi yaali anamatota. 7 [ ] Vano Yesu
ahawaaddelaga, wiira: <<Mudhe muaihareas anwiireni anamatata a athuss 18[7]
Mowaaguva aliwa yahaahiya¢ [ Findin Dictionary X
ahawoonaga addibila amohiz _

mmwanddeyani ni babiwa es '™ [mathavi o >
ahawiithanaga. Aliwa yahimw I
nmitharana Yeaan Headword Allomorphs Gloszes ~

dhinatoonya wi Zhuwawu aal
] 1.11 Moone Wambeela 22.

1.21 Nyuba dha matugun
eewa kayaali oolobelamoove
zﬂwaathﬂnqamc athu yahaal
N 1.24 Mu ewogelo ya eGere

I - FE T

mm

W

P4 (2) BT1 MRK 1:16 (Jeff Shrum)

L ] ii ﬂé W T C
| -
V]
|
\p W16 D Jesus was walkil Create Cancel | |
and Andrew. were throwing news mmw ure sea: 10 UIEY WeL & HIS1IeT eI o1 reaus U

This problem stems from the standard practice of using the singular form as the entry in the FLEx
dictionary, so the Find in Dictionary function will not find a match. If we parse the word into
morphemes in Analyze tab of FLEX’s interlinearizer, or approve an analysis of the word in Word
Analyses area, then the Find in Dictionary function can identify the plural prefix “ma-“ and the stem
“thavi” and return a match.

A) Example of parsing “mathavi”:



&# Takwane Thematic Dictionary - FieldWorks Language Explorer - O X

File  Send/Receive Edit View Data Inset Format Tools  Parser  Window  Help

Q Xl @l &g B (@ E BB | Takwane - -
Texts & Words Text

Intei Text 2] i K
i inear Texs Title Title [Tax 111620
Concordance Show All s - )
mplex Concordance "9 Mark 1:16-20
ord List Conordancs Fishing Info Baselne Gloss Analyze Tagging Print View Text Chart
Maruku (Title) 1:16 Word Yesu eeddaga seresere  wa Nyaza va oGalileya , zhawoonaga addibila abiili , Simawu &
| statistics 11213 Morphemes PP seresere  ***  nyaza PP sax o P PO
| N
Lex_Entries P seresers  ***  nyaza P e P - T
Marukn 1:12-13 (Heac lox Gloes =or e Rl T
M 1:14-15 Lex. Gram. Info. *** 4 ok n o Ex T hE hE wEE o ok
Word Gloss ocean; larzs lake T 4 4 wEE E ok
Maruku 1:14-15 (Hear Word Cat. n P P P e P P
Maruku 1:16-20 ni Andire , vowi waali anamatota
M: 1:16-20 (HEa( ni ke Ll ﬂ]ﬂ“l hk hk anamatota
2] Ll thﬂ\l rhE rhE anamatota
Maruku 1:1-8 -
and: with Aok Ak 3épl  net dek dek fishermen
Maruku 1:1-8 (Headin <Not Sure> ok dE w(NCl) n36 EE EE <Not Sure>
and: with s waw *x+  *2*  fohermen
Marukn 1:1-8 Footnot ~ ##+ . - o ska wbe aek
0 Lexicon Maruku 1:1-8 Footnot
@ Texts & Words | Maruku 1:1-8 Footnot Free
C% Grammar Maruku 1:1-8 Footmot 1:17 Word Vano Yesu  ahawaaddelaga , wiira : == Mudhe mugiharege , guwiireni anamatota  a athu
“2 Notebook Maruku 1:21-28 Morphemes vano FHE L kEE wiira FE S i anamatota R
. Maruku 1:21-28 (Heac Lex_ Entries vano Ha b wiira FE i FE anamatota FE i
Lists Mamrlens 191,98 B Lex Gloss then; now HhE HkE do: say wEE o wEE fishermen wEE o
armim e nnh N *hE L2 2 ; EE EE 2] EE 7 EE EE 2]
| 3 T, lecGmmio Naiswe : S S R
| 01/5ep/2015  Queue: -/ No Parssr Loaded  Sorted by Title /679

B) Example using Find in Dictionary function on a word with a FLEx word analysis:

Once we have successfully analyzed the morphemes of “mathavi” and entered a word analysis into FLEX,
the Find in Dictionary function can identify the stem and prefixes and returns matches on them from the
FLEx lexicon.

P4 (A) TKE_GaA MRK 1:16
T 4 B V- 46 Mo
(Matewuzhr 4.18-22; Luka 5.1-11)

16[ ] Yesu eeddaga seresere ya Nyaza ya oGalileya, ahawoonaga addibila abiili, Simawu n
Andire, evokedhaga munyaza, vowi yaali gnamatota. 7 [ | Vano Yesu
ahawaaddelaga, wiira: <<Mudhe mugiharege, guwiireni anamatota a athu=>. 8 |
Mowaaguva aliwa yahaahiyaga mathavi eewa, omuharaga. **[ | Egeeddile vang'ong, Yesu
ahawoonaga addibila amohi abiili. Tivago ni ddibile Zhuwawu, ahima a Zebedeyo. Egali

mmwanddeyani ni babilwa esasanyet picionary Entry )
ahawiithanaga. Aliwa yahimwihiyaga | _ o ani,
Gmuharaga Yesu. ntha\ﬂ I flShlng net

ma- n 5/6.pl
~ 1.6 Namavuhulela Eliyazi ahiwara nd:

dhinatoonya wi Zhuwawu aali namav
. 1.11 Moone Wambeela 22.12; Eza Open Lexicon Close

1.21 Nyuba dha matugumano Nd. ...c ces g g s o s e s s e i D8 51
eawa kavaali onlohelamonve. naar asuuzamao Malamulo. mbwenwve tetn




It is beyond the scope of this module to teach how to parse/analyze words in FLEx. That is a very
complicated topic and is a whole other skill that needs adequate time to study and master, but may well
be worth your while to learn. There is information in Help, and the resource “Introduction to Parsing”
found at HelpaRecourses.

IX Translation Suggestions taken from FLEx dictionary

Translation suggestions - FieldWorks looks through the lexicon to recommend words

e PT — Tools->Biblical Terms
¢ You must then make sure you are using Major Biblical Terms (SIL Semantic Domains)
o Do this by selecting (in the Biblical terms tool) File->Select Biblical Terms->Select Major Biblical
Terms (SIL Semantic Domains) and press OK in the dialog box
e You then select a Greek term
e You can then click the “Translation suggestions” button (at the top of ParaTExt’s Biblical term tool)
and FLEx will look up any words with:
o the selected domain or
o gloss in an entry

[Z4 Major Biblical Terms (SIL Semantic Domains): TKE_GaA

File Edit View Inset Tools ‘

TKE_GaA - Gos ~ Comparative Texts | =4 | & EE

= All terms * | Current Verse - F
Counts Found Category
Dﬂ-_E
adelphos
ouranos 01 G

That might lead you to alternate renderings. You can then add the “suggestion” as one of the renderings
for that key term.
A) Example of searching for possible renderings for a Greek word

Our example will be adeA@n --- sister; sister.believer in Matthew 12:50.

Procedure:

e Open project TKE AaG and navigate to Matthew 12:50.
 Right-click on any word in the verse.



e Click on View Biblical Termsa Current verse(s). Biblical terms tool will open to Mat 12:50.

« Click on FileaSelect Biblical Terms List, and select Major Biblical Terms List (SIL Semantic
Domains) if it is not the current Biblical terms list.

« Single click on adeAe@n, then click on the Translation Suggestion button on the tool bar. It will
return a window with words related by semantic domains, or similar glosses.

- All terms = | Curre
7 *  Tem Counts Fat
a- ]
Dn e m. These words have the same gloss as adelpha:
adelphos 0/1 sister: mMurogora
ouranos 0.1
Wards related by semantic domain to adelpha:
4.1.2 - Types of people:
enomuriha, mmwenye, mulobwana, muthengo, mwaana,
mwiddani, mwihiyanay
4.1.9.1.3 - Brother, sister:
ddibila, mulamuy, mulamus, murogora, murogoraga,
murogoraga a pogo, mMweneva
4.9.7.1 - Religious person: ddibila, mukumbuzi, muTakwani, namasuuza
L
£ TKE GaA

X MAT 12:50 Edit
Mwaha wi ole oneerana ofuna wa aE
a odhulu, oyene dili ddibilaaga,

murogoraga ni amma> .

T T N U N Y RPN U NSO

B) Example of adding a Translation Suggestion as an approved rendering of a Greek word

To insert a result of a Translation Suggestion look up, click on the desired rendering, and a new menu
will appear at the bottom of the pop up box, click on the Insert option and it will be inserted into the
Biblical terms list as an approved rendering for that Greek word.

Procedure:

e Single click on “murogora” in the pop up window. Additional buttons will become active at the
bottom.

e Click the Insert button. The pop up window will close, and “murogora” will appear as an approved
rendering for adeAe@n.

e Close the Biblical terms tool.




E Translation Suggestions n
L
These words have the same gloss as adelphs: ~ |

sister:

Words related by semantic domain to adelpha:

4.1.2 - Types of people:

enomuriiha, mmwenye, mulobwana, muthengo, r
mwiddani, mwihiyanaq

4.1.9.1.3 - Brother, sister:

ddibila, mulamuy, mulamuz, murogora, murogora ,

< >

murogora n sister of the opposite sex of the
speaker or person being referenced

X Using FLEX Interlinearizer on Paratext data

Bible books from Paratext can easily be imported into FLEx. After associating a Paratext project to a
Fieldworks lexicon, you can go to the Text & Words area of FLEx and select the Bible books you want to
import.



@, Takwane Thematic Dictionary - FieldWorks Languige Explorer
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Click on the Choose Texts button and you will get a list of the Bible books that are available in Paratext.
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Check off the Bible books that you want to import and then click the OK button. The books will be
imported into FLEx in sections like these below. You can now begin analyzing your translation in FLEx.

Example of Gospel of Mark (Maruku) after it was imported into FLEx
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Flex will only import from Paratext if it does not already have a current version of the text. We calculate a
checksum on the PT book and store that when we load it into Flex. The next time you choose anything in
this book, it sees the checksum hasn’t changed, so it doesn’t reload it. But as soon as you make a change
to the book in PT and save it, it will load it when you go to the Flex chooser, or if it’s already checked in
the chooser.

XI Tips and Warnings

1. Does not seem to search variant fields.

2. If you attempt to change writing systems or other configuration settings in FLEx after you have
launched it from within Paratext, you are given stern warnings of possible bad things that will
happen. It is recommended that you close Paratext before making any configuration changes to
FLEXx.

3. The Related Words function does not currently work on inflected words in the same way as the Find
in Dictionary functions does, which is to say that manually deleting affixes will not help the software
to find the stem and return any related words.

4. When using the “Translation Suggestion” function in the “Biblical Terms” Tool be aware that your
Biblical terms list will revert to the default Biblical terms lists as specified in “Project Properties”
every time you open the Biblical Terms Tool. It is recommended that you make “Major Biblical Terms
(SIL Semantic Domains)” your default Biblical terms list if you plan to use the “Translation
Suggestions” function frequently.

5. Both Paratext and Fieldworks have Send and Receive capabilities but they are separate from each
other. Anyone using S/R with both programs should read section 3.5 in Help...Resources...Technical
Notes on FieldWorks Send-Receive, or check the equivalent



http://fieldworks.sil.org/wp-content/TechnicalDocs/Technical%20Notes%200n%20FieldWorks%20Se
nd-Receive.pdf.Failure to heed these instructions may result in corrupted scripture inside of Flex that
requires technical help to try to unravel.

6. If you look up information about FLEx in ParaTExt’s help you may find references to exporting
interlinearized texts from Paratext and importing it into FLEx using a “FlexText” format. Currently
FLEx cannot correctly import such files from Paratext.

7. If you have problems getting the association between Paratext and FLEx to work, try restarting one or
both programs.

XIl Paratext Help File for Reference

How do I find a word in the dictionary for a project?
In a Paratext project for which you have associated a FieldWorks lexical pr...

In a Paratext project for which you have associated a FieldWorks lexical project, you can display
information about a word or display words related by semantic domain.

Display information about a word

If Display Spelling is not selected (on the Checking menu, the icon to the left of the Display Spelling menu
item does not have a box around it), do one of the following:

 Right-click a word, and then click Find in Dictionary....
e Click a word. Then, from the Edit menu, select Find in Dictionary....

If Display Spelling is selected (on the Checking menu, the icon to the left of the Display Spelling menu
item has a box around it), do the following:

e Click a word and then press Ctrl + D.

A dialog box appears. If FieldWorks Language Explorer is open, you might have to minimize the Paratext
window to see the dialog box.

If the word exists in the dictionary, the Dictionary Entry dialog appears with information about it.

If the word does not exist in the dictionary, the Find in Dictionary dialog appears. Click Create to open the
New Entry dialog and add that word to the dictionary. Then, you can enter information for that word.

A dictionary generally has a mix of whole words and morphemes which make up the words. In contrast,
the Wordlist command on the Tools menu makes a list of whole words found in the text of the project.

To display information about a word, you must have FieldWorks 7.1 (or later) installed on your computer.
Display words related by semantic domain

e Right-click a word, and then click Find Related Words....
e Click a word. Then, from the Edit menu, select Find Related Words....

A dialog box appears. If FieldWorks Language Explorer is open, you might have to minimize the Paratext
window to see the dialog box.

If the word is in the dictionary and shares semantic domains with other words, the dialog box will display
the related words.

Click a word to see its dictionary definition and words related to it.

To display words related by semantic domain, you must have FieldWorks 7.2 (or later) installed on your
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computer.

In Paratext 7.6 (and later), the "Find in Dictionary..." and "Find Related Words..." commands are also on
the Edit menu of the Wordlist.

Other Paratext help topics (search for them in Paratext help)

e How do I associate a lexical project with a Paratext project?
e What is FieldWorks Language Explorer?

XIll Harvesting words from Paratext for a Fieldworks Dictionary

If you want to harvest words from Paratext to add words or morphemes to a new or existing Fieldworks

database you can use the utility ParatextLexicon to convert data from the Paratext interlinearizer into
an SFM (Standard Format Marker) file that can then be imported into a Fieldworks database. The basic
steps are listed below.

e Step 1: Interlinearize text in Paratext project.

(If you want morphemes in the dictionary, then break the surface forms into morphemes and gloss them
as well as the surface/inflected forms. If you have not been breaking words into morphemes in the
interlinearizer prior to this, breaking words into morphemes in the Word List tool may be faster.

e Step 2: Download and install ParatextLexiconSetup.exe
e Step 3: Create a new Fieldworks project (if one does not exist).

It should have writing systems for the vernacular and one for all the glossing languages used. If you have
interlinearized the vernacular in more than one language (for Example, French and English), you will need
to already have writing systems for French and English configured as analysis languages in the
Fleldworks project. See Help in Fieldworks for more information. If you don't want all the glossing
languages from Paratext in your Fieldworks project, you can exclude those fields when importing.

e Step 4: Convert Lexicon.xml to a SFM file

Click on the button on the end of the “Paratext Lexicon” line.

Navigate to the lexicon.xml file for the Paratext project you wish to convert. Typically “c:\my Paratext
projects\xyz\lexicon.xml”.

Click on the button on the end of the “SFM File” line. Navigate to the folder where you want to store the
SFM that will be created, enter a meaningful name for that file and click Open.

Click convert

A pop-up will report a “count of analysis”, click “OK”

A pop-up will report a “count of entries”, click “OK”

A pop-up will report “conversion complete”, click “OK”.

e Step 5: Import the SFM file into the desired Fieldworks database.

(An existing one or the one you created in step 3.

File-->Import Standard Format data file

Map data to the appropriate writing systems. To exclude a gloss language from the import, click on the
marker in the Content mapping list, click Modify and choose Exclude from Import.

Assign converters if necessary, and import the SFM file into Fieldworks.

See Help or the document under the help menu, “Technical notes on SFM Database import” for more
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detailed information.

e Your words and morphemes and their glosses are now in your Fleldworks project. Add word
categories and other desired information.
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