
PrimerPro Setup Tutorial 

PrimerPro is a computer application designed to assist literacy personnel in the creation of 

scientifically designed primers, by capitalizing on the grammatical and phonological properties 

of these languages. The program and accompanying instructions help primer developers 

determine the teaching order of consonants, find buildable words for stories, check stories for 

untaught letters, and perform other key tasks in producing reading primers. 

This tutorial is a step-by-step procedure on how to set up PrimerPro to assist you in producing a 

primer.  The tutorial will walk through one scenario for using PrimerPro.  Please note that there 

are other scenarios for using PrimerPro that are just as valid.  Once you use this tutorial to learn 

PrimerPro, you should feel comfortable with how to set up PrimerPro in your situation.  This 

tutorial assumes that PrimerPro has never been run on your computer before now. 

You will also need a 4,000+ word list, in a Standard Format File or LIFT file, in UTF-8 

format.  This can be created using either Toolbox, FieldWorks or WeSay.  You will also need a 

4000+ words of edited text (so the spelling is correct!) in plain text files in UTF-8 format.  You 

will also need the orthography statement or sketch for the language. 

Installation 

The installation consists of one executable file: PrimerProSetup25.exe.  This contains all the 

files necessary for running the application. 

Below are the steps for installing PrimerPro. 

1. Run PrimerProSetup271.exe by double-clicking on it. 

2. Click Next. 

3. Browse for the desired folder for installing the application. Then click Next. 

4. Click Next. 

5. Click Install. 

6. Click Finish. 

7. In Windows Explorer, navigate to the PrimerPro subfolder in the Documents folder. Create 

a new subfolder in the PrimerPro folder.  You should give it the language name.  This will 

also be your project name.  This new folder will be your data folder for the project. 

PrimerPro will soon start putting info there. 

Starting PrimerPro 

You can start the program by double-clicking on the PrimerPro icon on the desktop. 

Creating a New Project 

The first thing you want to do is create a project. Below are the steps. 

1. On the File menu, click Create New Project. 

The Create New Project dialog box appears. 



2. In the Project Name box, enter the language name of the primer. 

3. Click OK. 

The project has been created and is now the current, or active, project.  An initial grapheme 

inventory has been created. 

Setup Folder Options 

The data folder and the template folder should be the same folder with the project name as a 

subfolder under the PrimerPro folder. To verify that your data folder and template folder has 

been set up properly, do the following: 

1. On the Tools menu, click Options, and then click the Folder tab. 

The Options dialog box appears, with the Folder tab selected. 

2. Verify the Data Folder box is correct.  

3. Verify the Template Folder box is correct.  

Verify File Options 

The current grapheme inventory file should be GraphemeInventory.xml in your data folder.  The 

current sight words file should be SightWords.xml in your data folder.  The current graphemes 

taught file should be GraphemeTaughtOrder.xml in your data folder.  The current parts of speech 

file should be PSTable.xml in your data folder.  To verify this, do the following. 

1. In the Options dialog box, click the File tab. 

The Options dialog box appears, with the File tab selected.  Verify the text boxes are 

correct. 

Now the current word list and current text data should be blank. 

Verify Format Options 

The default font should be Andika is you have the Andika font on your computer. Otherwise 

another font found on your computer will be displayed.  The highlight color should be black. To 

verify this, do the following 

1. In the Options dialog box, click the Format tab. 

The Options dialog box appears, with the Format tab selected. 

2. To change the default font, click Change Default Font. The Font dialog box appears. 

Navigate to the desired Font, Font style and Size. Click OK when done. 

3. To change the highlight color, click Change Highlight Color. The Color dialog box 

appears. In the Basic colors box, click the desired color. Click OK when done. The Options 

dialog box reappears with a sample of the desired color. 

Setup View Options. 

1. In the Options dialog box, click the View tab. 



The Options dialog box appears, with the View tab selected. 

2. Select English Gloss or select National Gloss or both whatever is appropriate. 

3. Select Part of speech. 

4. Select other choices, as needed. 

Setup SFM Options 

If you are going to import a Standard Format Marker (SFM) wordlist file, you will need to 

indicate which field codes you are using in the wordlist file. 

1. In the Options dialog box, click the SFM tab. 

The Options dialog box appears, with the SFM tab selected.  

2. Do any of the following: 

• In the Record Marker box, enter the desired field marker. This is the field marker that 

marks the beginning of a record. The default is lx. 

• In the Word Transcription box, enter the desired field marker. The default is lx. 

• In the English Gloss box, enter the desired field marker. The default is ge. 

• In the National Gloss box, enter the desired field marker. The default is gn. 

• In the Regional Gloss box, enter the desired field marker. The default is gr. 

• In the Parts of Speech box, enter the desired field marker. The default is ps. 

• In the Plural box, enter the desired field marker. The default is pl. 

• In the Root box, enter the desired field marker. The default is rt. 

Setup LIFT options 

If you are going to import a LIFT (Lexicon Interchange Format) wordlist file, you will need to 

specify the language codes (2 or 3 characters) used by the LIFT wordlist file.  For vernacular 

languages, it is usually the Ethnologue code. 

1. In the Options dialog box, click the Lift tab. 

The Options dialog box appears, with the Lift tab selected. 

2. Do any of the following: 

• In the Vernacular box, enter the desired language code used in the LIFT file to identify 

the vernacular language. 

• In the English Gloss box, enter the desired language code used in the LIFT file to 

identify the English gloss. It is usually en. 

• In the National Gloss box, enter the desired language code used in the LIFT file to 

identify the national gloss. 

• In the Regional Gloss box, enter the desired language code used in the LIFT file to 

identify the regional gloss. 



 

Set up CV Options 

These settings specify the symbols to be used when displaying the CV (consonant-vowel) 

pattern.  Usually you can just accept the default options.  If you want to change them, consult the 

Help facility for more information.  

Set up Punctuation Options 

These settings specify the symbols used for punctuation in the text data.  The Ending Punctuation 

List is used for determining where sentences breaks occur.  The General Punctuation List is used 

for determining what a word is. It will also determine where words breaks occur.  

1. In the Options dialog box, click the Punctuation tab. 

The Options dialog box appears, with the Punctuation tab selected. 

2. Do any of the following: 

• In the Ending punctuation list box, enter the punctuation symbols as a string of symbols 

that can be used at the end of a sentence. The default is ".?!". 

• In the General punctuation list box, enter the punctuation symbols as a string of 

symbols that can be used within a sentence. The default is " ;:-,". 

Setup Import Options 

These settings specify parameters for importing word list and text data. 

1. On the Tools menu, click Options, and then click the Import tab. 

The Options dialog box appears, with the Import tab selected. 

2. Do any of the following: 

• In the Maximal size of graphemes box, enter the largest number of characters a 

grapheme can have, for this language. The default is 4. 

• In the Characters to ignore box, enter the characters that you want the import process to 

ignore for either the word list or the text data. The application will handle these 

characters as if they do not exist in the data. An example of items you want PrimerPro to 

ignore would be chapter and verse numbers in a book of the Bible. 

• For the Characters to replace table, refer to the help facility. 

3. Click OK when done. 

Now you have completed setting up all the options settings. 

Initializing the Grapheme Inventory 

1. On the Tools menu, point to Grapheme Inventory, point to Initialize Grapheme Inventory, 

and then click From a word list or From a text data. 



If you selected From a word list, The Initialize Grapheme Inventory from the Word List 

dialog box appears. 

2. To select the word list, click Browse. Navigate and select the desired word list. 

3. To put consonants in the inventory, click Select consonants.  Select the desired consonants 

by adding them to the Selected Items list from the Available items list. Click OK when 

done. 

4. To put vowels in the inventory, click Select vowels.  Select the desired vowels  by adding 

them to the Selected Items list from the Available items list. Click OK when done. 

5. To put tones in the inventory, click Select tones.  Select the desired tones by adding them to 

the Selected Items list from the Available items list. Click OK when done. 

6. To put multi-graphs in the inventory, click Select multi-graphs.  Select the desired multi-

graphs by adding them to the Selected Items list from the Available items list. Click OK 

when done. 

7. Click OK. 

Completing the Grapheme Inventory 

You have already listed many graphemes which occur in the language. Now you are ready to 

complete the Grapheme Inventory list, with any symbols whose features need to be updated.   

You can now update the consonant list by adding the missing consonants (the ones that were not 

covered by the initialization process). 

1. On the Tools menu, point to Grapheme Inventory, and then click Update Consonant 

Inventory. 

The Update Consonant Inventory dialog box appears. 

2. To add a new consonant to the list, click Add. The Update Consonant Inventory dialog box 

reappears with empty fields. Enter the desired grapheme and its appropriate features. Click 

Save. Then click OK. The Update Consonant Inventory dialog box reappears. 

3. Click Previous to display the previous consonant in the list. Click Next to display the next 

consonant in the list. 

4. To find a given consonant, in the Find text box, type the grapheme of the consonant. Then 

click Find. The consonant is displayed.  If the application cannot find the grapheme, it means 

the grapheme is not in the consonant list and will need to be added. 

5. If you want to change the features of the displayed consonant, just make the appropriate 

changes and then click Save. 

6. Consonant combination feature is for consonant clusters that need to be taught. When you 

select Consonant Combination, all the other features become unavailable. Enter the 

graphemes of the consonant cluster in the adjacent text box, with one grapheme per line. 

Click Save to save the consonant, 

7. When done, click Exit. 



Second you will need to update the vowel list by adding the missing vowels (the ones that were 

not covered by the initialization process). 

1. On the Tools menu, point to Grapheme Inventory, and then click Update Vowel 

Inventory. 

The Update Vowel Inventory dialog box appears. The first vowel of the list is displayed, if 

any. 

2. To add a new vowel to the list, click Add. The Update Vowel Inventory dialog box 

reappears with empty fields. Enter the desired grapheme and its appropriate features. Click 

Save. Then click OK. The Update Vowel Inventory dialog box reappears. 

3. Click Previous to display the previous vowel in the list. Click Next to display the next vowel 

in the list. 

4. To find a given vowel, in the Find text box, type the grapheme of the vowel. Then click 

Find. The vowel is displayed.  If the application cannot find the grapheme, it means the 

grapheme is not in the vowel list and will need to be added. 

5. If you want to change the features of the displayed vowel, just make the appropriate changes 

and then click Save. 

6. Diphthong feature is for vowel diphthongs or combinations that need to be taught. When you 

select Diphthong, all the other features become unavailable. Enter the graphemes of the 

vowel diphthong in the text box below, with one grapheme per line.  Click Save to save the 

vowel 

7. When done, click Exit. 

Third, if you have a tonal language where tone is being marked, you will need to add all the tonal 

graphemes to the tone list. 

1. On the Tools menu, point to Grapheme Inventory, and then click Update Tone Inventory. 

The Update Tone Inventory dialog box appears. The first tone of the list is displayed. 

2. To add a new tone to the list, click Add. The Update Tone Inventory dialog box reappears 

with empty fields. Enter the desired grapheme and its appropriate features. Click Save. Then 

click OK. The Update Tone Inventory dialog box reappears. 

3. Click Previous to display the previous tone in the list. Click Next to display the next tone in 

the list. 

4. To find a given tone, in the Find text box, type the grapheme of the tone. Then click Find. 

The tone is displayed.  If the application cannot find the grapheme, it means the grapheme is 

not in the tone list and will need to be added. 

5. If you want to change the features of the displayed tone, just make the appropriate changes 

and then click Save. 

6. When done, click Exit. 

For more information on the grapheme inventory, refer to the help facility. 



Verifying the Grapheme Inventory  

Next you will want to verify that Grapheme Inventory has been correctly setup.  First you should 

display the Grapheme Inventory to verify that all the graphemes are there 

• On the View menu, click Grapheme Inventory. On the Format Menu, set the Word Wrap. 

All of the consonants, the vowels and the tones from the current grapheme inventory, are 

displayed in the active document.  .   

Second you should display the appropriate consonant charts to verify the consonants have the 

correct features. 

1. On Search menu, click Consonant Chart Search. 

The Consonant Chart Search dialog box appears. 

2. In the Consonant Chart Search dialog box, do any of the following: 

• Select Palatalized, if you want to display the palatalized consonant chart. 

• Select Labialized, if you want to display the labialized consonant chart. 

• Select Velarized, if you want to display the velarized consonant chart. 

• Select Prenasalized, if you want to display the prenasalized consonant chart. 

• Select Syllabic, if you want to display the syllabic consonant chart. 

• Select Aspirated, if you want to display the aspirated consonant chart. 

• Select Long, if you want to display the long consonant chart. 

• Select Glottalized, if you want to display the glottalized consonant chart. 

• Select Combination, if you want to display the combination consonant chart. 

If you choose none of them (the default choice), then all simple consonants are displayed. 

3. Click OK. 

Third you should display the Vowel Chart to verify the vowels have the correct features. 

1. On Search menu, click Vowel Chart Search. 

The Vowel Chart Search dialog box appears. 

2. In the Vowel Chart Search dialog box, do any of the following: 

• Select Nasal vowels, if you want to display the nasal vowel chart. 

• Select Long vowels, if you want to display the long vowel chart. 

• Select Voiceless vwl, if you want to display the voiceless vowel chart. 

• Select Diphthongs, if you want to display the diphthong chart. 

If you choose none of them (the default choice), then all the short oral vowels are 

displayed. 

3. Click OK. 



Fourth you should display the Tone Chart to verify the tone list. 

• On Search menu, click Tone Chart Search. 

The Tone Chart is displayed in the currently active document. 

If you need to make any changes to the grapheme inventory, you should do so and then go 

through the verification process again.  This is an iterant process. 

Importing Word List 

Now you are ready to import the wordlist.  The word list file needs to be a Standard Format 

Marker (SFM) file or a Lift file.  It must be a UTF-8 file as well.  If it is an SFM, verify that you 

have the correct field codes in the option settings to match the word list.  If it is a LIFT file, 

make sure you have the correct language codes in the option settings to match the word list. 

1. To import a wordlist file, do one of the following. 

• On the Tools menu, point to Word List, and point to Import and click Standard Format 

Lexicon. This will open a Standard Format Marker (SFM) file. 

• On the Tools menu, point to Word List, and point to Import and click LIFT Lexicon. 

This will open a Lexicon Interchange Format (LIFT) file. 

The Open dialog box appears. 

2. Navigate to and select the desired file, and then click Open. 

The wordlist is loaded. 

3. Click OK after wordlist has been imported. 

Now to verify the word list has been imported properly, display a listing of the current wordlist. 

• On the View menu, click Word List. 

A listing of the current wordlist, along with a count, is displayed in the active document. 

Information about each word is displayed with the word. 

You also might want to check to verify that you do not have any unwanted characters in the word 

list. If so, you may need to clean up the word list. 

• On the Tools menu, point to Word List, and then click Check against Grapheme 

Inventory. 

PrimerPro will display a list of any characters which are in the word list but are not in 

grapheme inventory. 

Importing the Text Data 

Now you are ready to import the text data.  The text data must be a UTF-8 plain text. 

1. On the Tools menu, point to Text Data, and then click Import. 

The Open dialog box appears. 

2. Navigate to and select the desired file, and then click Open. 

The text data is loaded. 



3. Click OK after text data has been imported. 

If you have several text files, you need to merge them. 

1. On the Tools menu, point to Text Data, and then click Merge. 

The Open dialog box appears. 

2. Navigate to and select the desired file, and then click Open. 

The selected text data is appended to the current text data. 

3. Click OK after text data has been merged with current text data. 

After merging all the files, you need to save the new file you’ve created. 

4. On the Tools menu, point to Text Data, and then click Export. 

The Save As dialog box appears. 

5. Navigate to the desired folder. 

In the File name text box, enter the desired file name for the new text data file, and then 

click Save. 

The current text data is saved to the selected file as a UTF-8 plain text file. This becomes the 

new current text data. 

6. Click OK after exporting. 

Now to verify the text data has been imported properly, display a listing of the current text data. 

• On the View menu, click Text Data. 

The text of the current text data, along with the paragraph count, the sentence count and the 

word count, is displayed in the currently active document. 

You also might want to check to verify that you do not have any unwanted characters in the text 

data. If so, you may need to clean up the text data. 

• On the Tools menu, point to Text Data, and then click Check against Grapheme 

Inventory. 

PrimerPro will display a list of any characters which are in the text data but are not in 

grapheme inventory. 

Generating Vowel Report 

The Vowel Report will show you all the vowels to be taught and their co-occurrences.  This is 

useful for verifying you have all the vowels required to be taught. 

1. To generate a vowel report, do the following. 

• On the Report menu, click Generate Vowel Report.  

The Vowel Report is displayed in a new active document named Vowel Report. 

2. To save the report as an RTF file, do one of the following. 

• Press <CTRL-S>. 



• On the File menu, click Save. 

• On the File menu, click Save As. 

The Save As dialog box appears. In the Save in list, navigate to the appropriate folder. 

In the File name box, type the appropriate name, for example, VowelReport.rtf. Click 

Save. 

Then you can print the report or display it in a word processor. 

3. Using the Vowel Report, review the vowel charts to verify the vowels have been set up 

correctly. If not, make the necessary changes to the current grapheme inventory. 

Using the Vowel Report, review the vowel co-occurrence chart. List any vowel sequences 

which are very common. The common sequences, two contiguous vowels, will need to be 

taught. They will need to be added in the current grapheme inventory as diphthongs. 

4. To make changes to current grapheme inventory, 

• On the Tools menu, point to Grapheme Inventory, and then click Update Vowel 

Inventory. 

The Update Vowel Inventory dialog box appears. The first vowel of the list is displayed, 

if any. 

5. Then do any of the following: 

• To navigate through the list, use Previous and Next. Previous will display the previous 

vowel in the list. Next will display the next vowel in the list. 

• To find a given vowel, in the Find text box, type the grapheme of the vowel. Then click 

Find. The vowel is displayed. 

• To add a new vowel to the list, click Add. The Update Vowel Inventory dialog box 

reappears with empty fields. Enter the desired grapheme and its appropriate features. 

Click Save. Then click OK. The Update Vowel Inventory dialog box reappears. 

• To change the features of the displayed vowel, set the appropriate features. Then click 

Save. 

• To delete the displayed vowel from the current grapheme inventory, click Delete. 

6. When done, click Exit. 

7. Rerun the vowel report to verify all the necessary changes have been properly entered. 

Whenever you update the grapheme inventory, you will need to re-import the word list and 

text data. 

Diphthong feature is for vowel diphthongs that need to be taught. When you select 

Diphthong, all the other features become unavailable. Enter the graphemes of the vowel 

diphthong in the text box below, with one grapheme per line. Then click Save. 

Generating Consonant Report 

The Consonant Report will show you all the consonants to be taught and their co-occurrences.  

This is useful for verifying you have all the consonants required to be taught. 



1. To generate a consonant report, do the following. 

• On the Report menu, click Generate Consonant Report.  

The Consonant Report is displayed in a new active document named ConsonantReport. 

2. To save the report as an RTF file, do one of the following. 

• Press <CTRL-S>. 

• On the File menu, click Save. 

• On the File menu, click Save As. 

The Save As dialog box appears. In the Save in list, navigate to the appropriate folder. 

In the File name box, type the appropriate name, for example, ConsonantReport.rtf. 

Click Save. 

Then you can print the report or display it in a word processor. 

3. Using the Consonant Report, review the consonant charts to verify the consonants have been 

set up correctly. If not, make the necessary changes to the current grapheme inventory. 

Using the Consonant Report, review the nasal co-occurrence chart. If you have syllabic 

nasals followed by a consonant, they will need to be taught differently from pre-nasalized 

consonants. Generally speaking, for a nasal followed by a consonant, if the point of 

articulation is the same, this combination is a pre-nasalized consonant (e.g. <mb>). 

Otherwise it is a syllabic nasal followed by a consonant (e.g. <md>). If a nasal followed by 

another identical nasal occurs (e.g. <nn>) in the language, then the first nasal is syllabic. 

Using the Consonant Report, review the consonant co-occurrence chart. If other consonant 

combinations appear, consider whether a digraph (this may include labialized, palatalized or 

aspirated consonants) has been overlooked and needs to be added to your grapheme 

inventory. Check with your literacy consultant if you find significant irregularities. 

4. To make changes to current grapheme inventory, do the following. 

• On the Tools menu, point to Grapheme Inventory, and then click Update Consonant 

Inventory. 

The Update Consonant Inventory dialog box appears. The first consonant of the list is 

displayed, if any. 

5. Then do any of the following: 

• To navigate through the list, use Previous and Next. Previous will display the previous 

consonant in the list. Next will display the next consonant in the list. 

• To find a given consonant, in the Find text box, type the grapheme of the consonant Then 

click Find. The consonant is displayed. 

• To add a new consonant to the list, click Add. The Update Consonant Inventory dialog 

box reappears with empty fields. Enter the desired grapheme and its appropriate features. 

Click Save. Then click OK. The Update Consonant Inventory dialog box reappears. 

• To change the features of the displayed consonant, set the appropriate features. Then 

click Save. 



• To delete the displayed consonant from the current grapheme inventory, click Delete. 

6. When done, click Exit. 

7. Rerun the consonant report to verify all the necessary changes have been properly entered. 

Whenever you update the grapheme inventory, you will need to re-import the word list and 

text data. 

Consonant combination feature is for consonant clusters that need to be taught. When you 

select Consonant Combination, all the other features become unavailable. Enter the 

graphemes of the consonant cluster in the adjacent text box, with one grapheme per line.  

Then click Save. 

Determining Grapheme Taught Order 

To determine the suggested Grapheme Taught Order, generate a Primer Progression Report. This 

report will display four searches: a grapheme frequency count on the word list, a recommended 

consonant teaching order based upon the word list, a grapheme frequency count on the text data 

and a recommended consonant teaching order based upon the text data. 

1. To generate a primer progression report, do the following. 

• On the Report menu, click Generate Primer Progression Report.  

The Primer Progression Report is displayed in a new active document named 

PrimerProgressionReport. 

2. To save the report as an RTF file, do one of the following. 

• Press <CTRL-S>. 

• On the File menu, click Save. 

• On the File menu, click Save As. 

The Save As dialog box appears. In the Save in list, navigate to the appropriate folder. 

In the File name box, type the appropriate name, for example, 

PrimerProgressionReport.rtf. Click Save. 

Then you can print the report or display it in a word processor. 

3. This report will display the suggested consonant teaching orders and the frequency counts 

from the word list and from the current text data. Using this report as input, draft a teaching 

order for the consonants. 

4. Modify the teaching order with the following additions or considerations: 

• Modify the order, if necessary, based on contrastive appearance of graphemes. 

• Add in the frequent vowel diphthongs you have identified in the grapheme inventory to 

the teaching order, such as <ai> and <iu>.  

• Concerning modified consonants (e.g. labialized, palatalized and aspirated), in the first 

lesson where you teach the modification, you should include the most frequent used 

form. Verify that it is after the corresponding plain consonant (e.g. <pw> should be 

taught after <p>). Then in the second lesson for the modification, you should teach two 



other modified consonants. Then in the third lesson for the modification, you should 

teach two or three other modified consonants. After the third lesson, consider the 

modification taught. 

• Concerning pre-nasalized consonants, do not teach <m> and <n> in the same lesson. You 

will teach them as separate modifications. 

• Add in the syllabic nasals you have identified that need to be taught to the teaching order. 

5. Enter the teaching order onto the Primer Progression Chart.  

Setup Conclusion 

Now you have completed the setup.  To exit PrimerPro, do the following. 

• On the File menu, click Exit. 

PrimerPro will remember the last current project and all its option settings.  The next time 

you start PrimerPro, the project will be selected with all its options setting.  The associated 

word list file and text date file will be automatically imported. 

 


