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Monday, Apr 16
 

Sharing

 

Note: LO = Learning Objective

 

Session 1: Introduction and Overview

Welcome

Introductions

Purpose

Logistics

Setup

Course Overview

Discussion Questions

Software to be installed

 

Session 2: Language Software Overview

LO:  The participant will know which language softwares to use with which  language development task

Language Software Overview (pdf)[2]

 

Session 3: LangTran

LO: The participant will be able to

set up LangTran for easy access to software on their computer or a flashdrive1.
set up ResilioSync for easy distribution of files at a workshop over WiFi2.

LangTran[3]

 

Session 4: Growth Plan

What is a growth plan?

Why the new growth plan?



What does the plan look like?

How to fill in the new growth plan?

Fill in the new growth plan.

Sign-up for a session to review your new growth plan.

 

Session 5: App Builder Installations

LO: The participants will

1. install the three App Builder applications including the Java and Android development kits.

2. Update the SDK installation as needed.

SAB Learning Tasks[4]

 

Tuesday, Apr 17
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Session 1: Paratext 8 -Registration and Migration

LO:

The participants will be able to explain the difference between direct registration and third-party registration1.
The participants will learn how to exercise their role as Paratext Registry Supporter to troubleshoot registration issues.2.

Know if the registration was made without their Paratext 7 code.
Know what version of Paratext a user is using.
Know how to remove wrongful registrations for back translations or notes projects.

See Is the type of your project indicated correctly[5] on the Paratext 8 website.
Know if a user has not connected to the Internet in a long time.
Know which projects have migrated to Paratext 8
Know all the members on a given project

The participants will review Migration issues and know how to use a migration checklist.3.
The participants will be able to perform a project conversion when necessary.4.

Session 2: Paratext 8 - Spell Check

LO:

The participants will know to do global spell checking1.
The participants will know how to do local spell checking2.
The participants will know what not to do for spell check.3.

Spell Check (ppt)[6]

Session 3: Paratext 8 - Parallel Passages

LO: The participants will

use the Parallel passages tool to compare and constrast a variety of parallel passages.1.
make changes as necessary2.
track the passages which have been checked3.
use the filters to identify any passages which have changed since they were checked.4.



ParallelPassages EHandout 2018[7]

PT Comparing & Contrasting Parallel Texts 2018[8]

Session 4: Bloom

LO:

The participant will know how to create and publish a basic book.1.
The participants will know to create shell book.2.
The participants will know to create a talking book3.
The participants will know to create  language specific templates4.

Learning Tasks:

1.      Create a new collection called Basic Books 2018.

2.      Create a basic book using the Agama story.

3.      Publish the Agama book as a pdf file.

4.      Create a new collection call Shell Books 2018

5.      Create a shell book using Lost Sheep story.

6.      Make the Agama Book into a talking book.

7.      Publish the Agama book as a taking e-pub book

8.      Create a language specific templates for English (see create language specific templates.pdf)

 

Session 5: NRSI Report (David)

Accessing Language Resources (odp)[9]

Wesnesday, Apr 18
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Session 1: Paratext 8 - Project Plan Setup

LO:

The participants will know how to create a project plan from a base plan.1.
The participants will know how to modify a project plan2.
The participants will know how to configure task settings3.
The participants will know how to assign automatic checks to stages4.
The participants will assign tasks to team members5.

Project Plan Setup (ppt)[10]

Session 2-3: Paratext 8 - Using Project Plan

LO: The participants will

use the project plan to identified tasks which have been assigned to them.1.
mark individual tasks as completed for a variety of types of tasks (by project, book or chapter).2.
bulk update the progress of an ongoing project, (i.e. mark complete stages as finished)3.



display the progress of your project4.
display a progress graph.5.

PT8 Using The Project Plan[11]

PT8 Using The Project Plan Learning Tasks EHO[12]

Session 4: Reading App Builder

LO:

The participants will know what types of documents and files can be used to create a Reading App1.
The participants will know how to apply audio files to a Reading App and synchronize the results2.
The participants will be able to configure the app to compile and install directly to their Android phone3.
The participants will be able to use Audacity to create timing files for audio enabled apps.4.

Learning Tasks:

Create the app with Worship.txt
Add the mp3 audio What a Wonderful Name.mp3
Create the phrase list .phrase
Open mp3 in Audacity
Add a Labels Track
Place Timing Labels Assistant in a writable folder
Run Timing Labels Assistant, select phrase list
Place phrase list on the right side of screen
Play song, press tab as it starts, then tab after each phrase.
"Export Lables" (Timing file) from file menu
Import Timing File into RAB
Finetune timings, right-click on mp3 in RAB, select Finetune
Build app

Session 5: Teaching a workshop

LO:

The participants will know to plan a LT workshop1.
The participants will plan one LT workshop  using the workshop planning form2.

Learning Tasks:

Connection:

First have each participant from LTCT2017 will  share their experience from the workshop that they planned at LTCT2017 using
Workshop Report Form.

Content:

Planning the workshop

Be proactive, if you can. Train users in the tools that will help them in their tasks before they come to you asking for help.
What is it you are being asked to teach? “Teach Paratext” or “Teach Bloom” is not sufficient. You need to ask questions to
learn what tasks the participants will need to do.  Then you create your training program based on the learning objectives
of the participants.
Create your list of learning objectives, and then get them approved by the person who is asking you to teach the course.
You may need to plan several meetings in advance of the workshop to

Before the workshop

Set requirements for the users.  You must set a minimum level of skill for the participants to have in order to succeed.
Communicate to the participants to let them know what they will be learning, and how to prepare for the course.
Plan the venue. Many details must be resolved:

Come early to test the setup
Keep weather in mind, seasons.



Power adapters
Meals should be provided
Enough power outlets without daisy-chaining
Adequate WiFi
Enough tables and chairs and adequate space.
Is the projector bright enough?  The wall white enough?
Is the area too noisy?
Climate?

Find teaching assistants
One teacher/assistant for every 5 participants

Plan the seating by pairing more experienced participants with less experienced participants. Then make it clear that they
have a responsibility to help others when they are ahead of the class.

During the workshop

Just follow Kent’s example

Teaching the workshop

Introduce the software by explaining the problem that it solves.1.
Explain the difficult situation users facea.
If users can relate to the example situation, they will be very interested in your solution.b.

Now explain how the technology you are going to teach provides a solution.2.
Explain what the software is for. What is its primary purpose?3.

Too often, 10 minutes into my presentation, a hand would go up: “Why are we doing this? What is it for?”a.
Check the computers for antivirus and for general problems.  This takes time4.
Install the software5.
Lesson 16.

Overview of the software.  Goal is to make everyone comfortable opening and closing it. And familiar enough witha.
what is strange and different.
Focus on rather simple aspects and enable them to succeed at small tasks.b.

Lessons 2-10??7.
Break the material into chunks that are manageable based on the skill level of the user.a.
Allow enough time for participants to test what they have learned.b.
Always include a Wrap-up moment at the end of each session:c.

Now that you understand what this tool is capable of, how do you see this being applied in your context?i.

 

Challenge

Explain the workshop planning form.

Have each participant plan a workshop for the coming year using the workshop form.

Changes:

Have each participant have their filled-out form checkedave H by an instructor.

Thursday, Apr 19
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Session 1:  Paratext 8  - Back Translations

LO: The participants will

Create a back translation project (based on the translation project).1.
Enter the back translation for a number of verses.2.
Set the satus of  translated verses as finished.3.
Identify verses which have changed after they were finished.4.



Setup interlineariser to generate an interlinearised back translation.5.
Add glosses to words, break words into morphemes, link words into phrases, add words as needed to interlinearise a6.
number of verses.

PT8 Back Translation EHO[13]

PT8 Back Translation[14]

Session 2: Paratext 8 - Using Paratext with Logos

Setting up TW Logos for Success[15]

Session 3: Paratext 8 - Setting up for Success

Setting up P8 for Success[16]

Session 4: Bloom

LO:

The participants will be aware of the new features in Bloom1.
The participanfs will know how to put a book in the Bloom Reader2.
The participants will know to create  language specific templates3.

Learning Tasks

Continue to create a language specific templates for English (see create language specific templates.pdf)1.
Install Bloom Reader on an Android device.  Published the Agama talking book using Bloom Reader2.
Demo the following:3.

Zoom in and out a page
Input special characters by holding key down.
Choose a topic for the front cover
Add a logo to title page
Add a text box to an image

Session 5: LSDev Report (John)

SIL Software Development (pdf)[17]

 

Friday, Apr 20
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Session 1:  Regular Expressions

By the end of these sessions, you will

define filters in FLEx
define filters in the Paratext wordlist to find words
use RegEx Pal to correct errors
search in an Android app
play the RegEx reptiles game on your Android (optional)

RegEx Learning Tasks[18]

 



Session 2: HearThis (John)

HearThis (ppt)[19]

 

Session 3: Reading App Builder

Continuation of Wednesday's session

 

Session 4: Scripture App Builder

 

LO: The participants will

create apps suitable for reviewers (with annotation feature).1.
create apps that allows the text to be edited.2.
create a variety of apps suitable for readers/listeners thatinclude both new and existing features.3.
Use aenaes to synchronise the audio files.4.
Use the App publishing checklist to see if you are ready to distribute.5.

SAB Learning Tasks[20]

Session 5: Language Forge

LO:

The participant will know how to build an online lexicon using language forge1.

Learning Tasks:

Connection:

Why would you want to use Language Forge?

Content:

Sign in to Language Forge1.
Add participants to Kent Test FLEx project2.
Find entries3.
Add new entries4.
Change existing entries5.
Delete an existing entry6.
Synchronize7.
Using Configuration, add adjective as Parts of Speech8.
Using Configuration, add audio9.
Using View Settings, indicate who can see what10.

Challenge

Setup a FLEx project to do S/R1.
Start a project in Language Forge2.
Get a project from Language Depot3.
Add, edit, find and delete entries4.
Synchronize5.



Saturday, Apr 21
 

Session 1: Problem Solving

LO

Work towards solving many real-life problems. (These will include activities related to target competencies in their growth1.
plans).
Share their ideas of possible solutions with the group.2.

Problems

Create a Bloom book from the Africa Storybook The boy who ran away. (The_boy_who_ran_away.pdf)1.
 
Create a Reading Android app from the book My Baby Boy found in the Bloom Library.2.
 
Convert the Toposa dictionary (DIC Top-Eng,txt) into MDF.3.

 

Session 2-3: Keyman

LO: Participants will

Design a keyboard on paper1.
Set up Keyman Developer and create a project.2.
Transfer the keyboard design to Keyman Developer using character map and drag and drop.3.
Do some basic coding for keyboard logic4.
Create a visual keyboard5.
Create a touch keyboard for mobile devices6.
Test and distribute the keyboard as a Keyman Package7.

Course content: Keyman Developer 10 - Beginning[21]

Monday, Apr 23
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Session 1:  FLEx 8 - Lexicon Edit 1 (Jeremiah)

Objectives:

The participants will know how to add entries in the lexicon1.
The participants will know how to find entries in the lexicon.2.
The participants will know how to delete entries in the lexicon.3.
The participants will know how to add multiple senses in the lexicon4.
The participants will know how to add homographs in the lexicon.5.
The participants will know how to merge entries and senses in the lexicon6.
The participants will know how to configure the columns in the Entries pane.7.

Learning Tasks:

How to add an entry? How to find an entry?1.
How to add a second sense to an entry? How to add homographs?2.
How to delete an entry.3.
How to merge entries? How to merge senses?4.
How to move senses into a new entry? How to move a sense to another entry?5.
How to add affixes? How to add variants?6.
How to add complex forms?7.



 

Session 2:  FLEx 8 - Lexicon Edit 2 (Benedict)

Objectives:

The participants will know how to change the field visibility of a field in the lexicon1.
The participants will know how to add and edit affixes in the lexicon.2.
The participants will know how to add and edit variants in the lexicon.3.
The participants will know how to add and edit complex forms in the lexicon.4.

Learning Tasks:

Change the field visibility of a field in the lexicon1.
Add and edit affixes in the lexicon2.
Add and edit variants in the lexicon. What are variants?3.
Add and edit complex forms in the lexicon.4.
What are complex forms?5.

Session 3:  FLEx 8 - Import (David)

Objectives:

The participants will know how to create new project in FLEx.1.
The participants will know how to import standard format (SFM) lexicon file into FLEx2.
The participants will know how to import a LIFT lexicon file into FLEx.3.
The participants will know how to export a lexicon as a SFM or as a LIFT file.4.

Learning Tasks:

Import SF Data

Create new project called Kusaal.1.
Backup project.2.
In the File menu, point Import and click Standard Format Lexicon.3.
The Import Standard Format lexical data dialog box appears.4.
Click Next.5.
In the Database File box, select Kusaal-sfm.db. Set Settings info. Click Next.6.
Click Next.7.
Verify mappings and make appropriate changes. Click Next.8.
Verify markers. Click Next.9.
Click Next.10.
Click Generate Report. Check report. Click Next.11.
Click Finish.12.

Talk about difficulties.

Import LIFT Data

Create new project call Kusaal.1.
Backup project.2.
In the File menu, point Import and click LIFT Lexicon.3.
The Import/Merge from LIFT File dialog box appears.4.
Browse for Lift File (Kusaal.lift). Click OK.5.

 Export Learn how Learn how to   SFM and LIFT.

In the File menu, click Export.1.
The Export dialog box appears.2.
Export as either SFM or LIFT.3.

 



Session 4:  FLEx 8 - Interlinearization (Stephen)

Objectives:

The participants will know how to add text to the baseline tab in Text & Words section1.
The participants will know how to interlinearize text using the Analyze tab.2.
The participants will know how to add a lexeme to the lexicon via the Interlinearization process.3.
The participants will know how to add a free translation for text.4.
The participants will know how to add a note to the text.5.
The participants will know to configure the interlinear lines.6.

 

Learning Outcomes:

 Know how to add text to the baseline tab in Text & Words section1.
 Know how to interlinearize text using the Analyze tab.2.
 Know how to add a lexeme to the lexicon via the Interlinearization process.3.
 Know how to add a free translation for text.4.
 Know how to add a note to the text.5.
 Know how to configure the interlinear lines.6.

Session 5:  FLEx 8 - Word Collection ( James)

Objectives:

The participants will know how to add words to the lexicon using semantic domains.1.
The participants will know how to generate a classified dictionary.2.

Learning Tasks:

Demonstration:

Participants are encouraged to watch and then do the activity that folows

In Lexicon area, click Collect Words.
Select 2.1.1 Head
Add the following words with a brief definition:  a̱ghyi, a̱nu, a̱tanu, A̱ghyighyak A̱pyia̱, a̱ma̱nfwuo, pyia̱, fwufwo, zwoi.

***The program creates a new lexical entry for each unique word you enter, and a sense for each unique definition.

Activity:

Select 3.5.1.4.4 (Say fairwell)

Add : bye, goodbye, cheerio, see you, later words add definition

**Use the Lexicon edit to view the result of your entries 

 

Summary:

State the importance of the Word Collection tool in Flex.

Tuesday, Apr 24
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Session 1: FLEx 8 - Publication (Musie)

The participants will know how to configure the dictionary.1.
The participants will know how to use pathway for generating a publishable dictionary.2.
The participants will know how to create stylesheet in Pathway using the Pathway configuration tool.3.
The participants will know how to publish a lexicon to Webonary.4.

Learning Tasks:

Configure Dictionary.  To configure dictionary do the following.

Open Sena3 project.1.
In the View menu, point to Lexicon and click Dictionary.  The dictionary is displayed2.
To configure dictionary, in the Tools menu, point to Configure and click Dictionary. The Configure Dictionary View dialog3.
box appears.
In the Choose Dictionary view to configure box, select Root-based.4.
Click OK. The dictionary is redisplayed.  Let’s go back to the Configure Dictionary View dialog box.5.
In the Tools menu, point to Configure and click Dictionary. The Configure Dictionary View dialog box appears.6.
In the Configure box, check the appropriate items.7.
Click OK.8.
Configure the dictionary to your own preferences.9.

Generating a publishable dictionary using Pathway. You can use Pathway to format your dictionary for a selected output
environment.

Open Sena 3 project.1.
In the File menu, click Export.  The Export dialog box is displayed.  Select Dictionary – Pathway.  And then click Export.2.
The Print via… dialog box appears. Explain and select options. Click OK.3.
Select Enable Macros.  The dictionary is displayed in Open Office.4.
Close Open Office.5.
Start Pathway Configuration Tool.6.
Click Save As to create a new style. Click Info tab, to change the name.7.
Click Properties tab and explain options.8.
Click Preview tab.9.
Now run Pathway again using the new stylesheet.10.

Creating stylesheet in Pathway

Start Pathway Configuration Tool.1.
Select one of the stylesheet.2.
Click Save As to create a new style.3.
From the right tab Click Info tab, to change the name.4.
Click Properties tab and explain options.5.
Click Preview tab.6.
Now run Pathway again using the new stylesheet.7.
Create your own stylesheet using Pathway Configuration Tool.8.

Publishing on a webonary

Webonary is a place where you publish a dictionary online. To publish a dictionary on webonary,  you will need to register on
webonary website. After the Webonary staff person, creates your account, you will receive an email with your account
credentials.

From the File menu, click Upload to Webonary1.
Type the name portion of your site url (typically the language name, without http://). The ".webonary.org" is2.
programmatically appended to complete the url.
Type your username.3.
Type your Webonary password.4.
Choose the publication.5.
Choose one of the available views.  The views you can choose are only those that are  available to the publication you6.
chose in the previous step. Available views were set in the Manage Dictionary Views dialog box.
Select any reversal indexes that you want to include with the vernacular dictionary.7.
Click Submit. The dictionary and any reversal indexes are uploaded to Webonary.[22]8.



Session 2: FLEx 8 - Parsing (Frans)

The participants will know how to use the parser to parse a word.1.
The participants will know how to use the parser to parse text.2.
The participants will know how to use word analysist feature to approve and assign analyses.3.

Learning Tasks:

Connection:

Define morphological parsing and point the learners to the videos

Content:

Present a PowerPoint demo[23] on morphological parsing showing how to use the parser and how to use the word analysis feature

Challenge

Explain how to parse words and text and allow participants to do some practice.
Explain how to use the word analysis feature.
Participants will analyze and assign some words

Changes:

Participants will parse some words and show to the instructor.

 

Session 3: FLex 8 - Collaboration (Rauf)

Objectives:

The participqnts will know to verify that FLEx is using the current FLExBridge.1.
The participants will know how to collaborate between two FieldWorks project on separate PCs.2.
The participants will know how to collaborate between a FieldWorks lexicon and a WeSay project.3.

Learning  Tasks:

Session Tools:

Ensure the installation of Flex & WeSay on participant computers.1.
Ensure the presence of at least one flash drive per team.2.
Ensure the presence of a dictionary data to work on.3.

Session Activity:

Divide the participants into teams of 3 or 4.1.
Copy the dictionary data, (Sena2) into PCs.2.

Session stepping through:  follow up step by step using (Flex session – Collaboration sheet)

Introduction & Chorus updates. 1.
How to collaborate flex to flex using USB. 2.
How to collaborate flex to flex using Internet.3.
How to collaborate between flex & WeSay.4.

 

Session 4: Software Snapshots

Topics covered were:

PrimerPro1.
PrimerPrep2.



MLE Word List3.
Bloom Training4.
Paratext 8.15.
Android Tablets over Windows Desktop Computers6.

 

Session 5: Scripture App Builder

Continuation of Friday's sessions
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Session 1: Dictionary App Builder

LO:  

1.      The participant will know how to build a dictionary app from a Language Forge project

2.      The participants will know how to build a dictionary from a WeSay project.

Learning Tasks

Connection:

Discuss Learning Obljectives. 1.
Discuss Features. 2.
Demo the Kasem app.3.

Content:

Show the participants how to build an app from a Language Forge project.1.
Have the participants build with the instructor a PigLatin Dictionary App with audio.2.
Have the participants install and run this app on their Android device.3.

Challenge:

The participants will create a Dictionary App on their own from a WeSay project.1.
The participants will install and run this app on their Android device.2.
The participants will create dictionary app from a FLEx project.3.
The participants will install and run this app.4.

 

Session 2-3: Problem Solving

LO

Work towards solving many real-life problems. (These will include activities related to target competencies in their growth1.
plans).
Share their ideas of possible solutions with the group.2.

Problems

Write a bug report for a FLEx problem that we discovered in the workshop.1.
Develope a touch keyboard for Dinka using Keyman 102.



 

Session 4: Software Snapshots

Topics covered were:

Paratext Lite1.
Adapt It2.
Chorus Hub3.
Using Paratext with FLEx4.
Paratext Sharing Tips5.
Scripture Forge6.

 

Session 5: Debrief and Evaluation

Evaluations

Certificate presentation

Picture presentation

Video

Thanks to participants

Thanks to staff

Cleanup

 [1] https://lingtran.net/2018+Africa+Nairobi
 [2] https://lingtran.net/dl1231
 [3] http://lingtransoft.info/apps/langtran
 [4] https://lingtran.net/tiki-download_file.php?fileId=1245
 [5] http://pt8.paratext.org/2018/01/04/migration-preparation-issues
 [6] http://lingtran.net/dl1232
 [7] https://lingtran.net/tiki-download_file.php?fileId=1248
 [8] https://lingtran.net/tiki-download_file.php?fileId=1247
 [9] http://lingtran.net/dl1254
 [10] http://lingtran.net/dl1233
 [11] https://lingtran.net/tiki-download_file.php?fileId=1253
 [12] https://lingtran.net/tiki-download_file.php?fileId=1252
 [13] https://lingtran.net/tiki-download_file.php?fileId=1236
 [14] https://lingtran.net/tiki-download_file.php?fileId=1237
 [15] https://lingtran.net/Set+up+TW+Logos+for+Success
 [16] https://lingtran.net/Setting+up+P8+for+Success
 [17] http://lingtran.net/dl1257
 [18] https://lingtran.net/tiki-download_file.php?fileId=1249
 [19] http://lingtran.net/dl1255
 [20] https://lingtran.net/tiki-download_file.php?fileId=1250
 [21] https://lingtran.net/Keyman+Developer+10+-+Beginning
 [22] https://lingtran.net/
 [23] http://lingtran.net/dl1258
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