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PrimerPro Setup Tutorial for Syllabary Languages
PrimerPro is a computer application designed to assist literacy personnel in the creation of scientifically designed primers, by
capitalizing on the grammatical and phonological properties of these languages. The program and accompanying instructions help
primer developers determine the teaching order of consonants, find buildable words for stories, check stories for untaught letters,
and perform other key tasks in producing reading primers.

This tutorial is a step by step procedure on how to set up PrimerPro to assist you in producing a primer.  The tutorial will walk
through a scenario for using PrimerPro with language that has a syllabary writing system.  Please note that there are other
scenarios for using PrimerPro that are just as valid.  Once you use this tutorial for learning PrimerPro, you should feel
comfortable on how to set up PrimerPro in your situation.  This tutorial assumes that PrimerPro had never been run on your
computer before now.

You will also need a 4,000+ word list, in a Standard Format File or LIFT file, in UTF-8 format.  This can be created using either
Toolbox, FieldWorks or WeSay.  You will also need a 4000+ words of edited text (so the spelling is correct!) in plain text files in
UTF-8 format.  You will also need the orthography statement or sketch for the language.

This tutorial is based version 2.5 of  PrimerPro

Installation

The installation consists of one executable file: PrimerProSetup254.exe.  This contains all the files necessary for running the
application.

Below are the steps for installing PrimerPro.

Run PrimerProSetup25.exe by double-clicking on it.1.
Click Next.2.
Browse for the desire folder for installing the application. Then click Next.3.
Click Next.4.
Click Install.5.
Click Finish.6.
In Windows Explorer, navigate to the PrimerPro subfolder in the Documents folder. Create a new subfolder in the7.
PrimerPro folder.  You should give it the language name of the primer.  This will also be your project name.  This new
folder will be your data folder for the project. Primer Pro will soon start putting info there.

Starting PrimerPro

You can start the program by double-clicking on the PrimerPro icon on the desktop.

Creating a New Project

The first thing you want to do is create a project. Below are the steps.

On the File menu, click Create New Project.  The Create New Project dialog box appears.1.
In the Project Name box, enter the language name of the primer. Click OK.  The project has been created and is now the2.
current, or active, project.  An empty grapheme inventory has been created.

Verify Folder Options

The data folder and the template folder should be the same folder with the project name as a subfolder under the PrimerPro
folder. To verify that your data folder and template folder has been set up properly, do the following:

On the Tools menu, click Options, and then click the Folder tab.  The Options dialog box appears, with the Folder tab1.
selected.
Verify the Data Folder box is correct.  If not, click the adjacent Browse button. In the Browse for Folder dialog box,2.
navigate to your data folder, which you created after installation. Select it.  Then click OK.
Verify the Template Folder box is correct.  If not, click the adjacent Browse button. In the Browse for Folder dialog box,3.
navigate to your data folder and select it.  Then click OK.
Click OK when done.4.



Verify File Options

The current grapheme inventory file should be GraphemeInventory.xml in your data folder.  The current sight words file should
be SightWords.xml in your data folder.  The current graphemes taught file should be GraphemeTaughtOrder.xml in your data
folder.  The current parts of speech file should be PSTable.xml in your data folder.  To verify this, do the following.

On the Tools menu, click Options, and then click the File tab.  The Options dialog box appears, with the File tab selected.1.
Click OK when done.2.

Now the current word list and current text data should be blank.

Verify Format Options

The default font should be Andika is you have the Andika font on your computer. Otherwise another font found on your computer
will be displayed.  The highlight color should be black. To verify this, do the following

On the Tools menu, click Options, and then click the Format tab.  The Options dialog box appears, with the Format tab1.
selected.
To change the default font, click Change Default Font. The Font dialog box appears. Navigate to the desired Font, Font2.
style and Size. Click OK when done.
To change the highlight color, click Change Highlight Color. The Color dialog box appears. In the Basic colors box, click3.
the desired color. Click OK when done. The Options dialog box reappears with a sample of the desired color.
Click OK when done.4.

Setup View Options.

On the Tools menu, click Options, and then click the View tab.  The Options dialog box appears, with the View tab1.
selected.  Select English Gloss or select National Gloss or both whatever is appropriate.
Select Part of speech.2.
Select other choices, as needed.3.
Click OK when done.4.

Setup SFM Options

If you are going to import a Standard Format Marker (SFM) wordlist file, you will need to indicate which field codes you are using
in the wordlist file.

On the Tools menu, click Options, and then click the SFM tab.  The Options dialog box appears, with the SFM tab selected.1.
Do any of the following:2.

In the Record Marker box, enter the desired field marker. This is the field marker that marks the beginning of a
record. The default is lx.
In the Word Transcription box, enter the desired field marker. The default is lx.
In the English Gloss box, enter the desired field marker. The default is ge.
In the National Gloss box, enter the desired field marker. The default is gn.
In the Regional Gloss box, enter the desired field marker. The default is gr.
In the Parts of Speech box, enter the desired field marker. The default is ps.
In the Plural box, enter the desired field marker. The default is pl.
In the Root box, enter the desired field marker. The default is rt.

Click OK when done.3.

Setup LIFT options

If you are going to import a LIFT (Lexicon Interchange Format) wordlist file, you will need to specify the language codes (2 or 3
characters) used by the LIFT wordlist file.  For vernacular languages, it is usually the Ethnologue code.

On the Tools menu, click Options, and then click the Lift tab. The Options dialog box appears, with the Lift tab selected.1.
Do any of the following:2.

In the Vernacular box, enter the desired language code used in the LIFT file to identify the vernacular language.
In the English Gloss box, enter the desired language code used in the LIFT file to identify the English gloss. It is
usually en.
In the National Gloss box, enter the desired language code used in the LIFT file to identify the national gloss.
In the Regional Gloss box, enter the desired language code used in the LIFT file to identify the regional gloss.

Click OK when done.3.

Set up CV Options

These settings specify the symbols to be used when displaying the CV (consonant-vowel) pattern.  Usually you can just accept the



default options.  If you want to change them, consult the Help facility for more information.

Set up Punctuation Options

These settings specify the symbols used for punctuation in the text data.  The Ending Punctuation List is used for determining
where sentences breaks occur.  The General Punctuation List is used for determining what a word is. It will also determine where
words breaks occur.

On the Tools menu, click Options, and then click the Punctuation tab.  The Options dialog box appears, with the1.
Punctuation tab selected.
Do any of the following:2.

In the Ending punctuation list box, enter the punctuation symbols as a string of symbols that can be used at the end
of a sentence. The default is ".?!".
In the General punctuation list box, enter the punctuation symbols as a string of symbols that can be used within a
sentence. The default is " ;:-,".
Click OK when done.

The Options dialog box appears, with the Lift tab selected.3.

Setup Import Options

These settings specify parameters for importing word list and text data.

1. On the Tools menu, click Options, and then click the Import tab. The Options dialog box appears, with the Import tab selected.

2. Do any of the following:

In the Maximal size of graphemes box, enter the largest number of characters a grapheme can have, for this language. The
default is 4.
In the Characters to ignore box, enter the characters that you want the import process to ignore for either the word list or
the text data. The application will handle these characters as if they do not exist in the data. An example of items you want
PrimerPro to ignore would be chapter and verse numbers in a book of the Bible.
For the Characters to replace table, refer to the help facility.

3. Click OK when done.

Now you have completed setting up all the options settings.

Setting up the Grapheme Inventory

Now you are ready to add graphemes to  the Grapheme Inventory list.   You will now update the syllograph list by  searching for
syllographs in  a text file or a word list.

On the Tools menu, point to Grapheme Inventory,  and click Initialize Syllograph Inventory.  The Initialize Syllograph1.
Inventory dialog box appears.
Do one of the following.2.

Click Initialize using text data file, if you want to use a text data file for finding syllographs.  Navigate to the
desired file, select it and click Open.  The Initialize Syllograph Inventory dialog box reappears.
Click Initialize using word list file, if you want to use a word list file for finding syllographs.  Navigate to the desired
file, select it and click Open.  The Initialize Syllograph Inventory dialog box reappears

Click OK when done.  All unique symbols found in the text data file or the word list file have been added to the grapheme3.
inventory.
To add category information for each syllograph to the grapheme inventory, on the Tools menu, point to Grapheme4.
Inventory,  and click Update Syllograph Inventory.  In the Update Syllograph Inventory dialog box, The first grapheme is
displayed, enter the desired category information in one or more of  three category textboxes.  You have a primary
category, a secondary category and tertiary category.  These categories can be used for grouping syllographs in a
particular group for teaching order purposes.
To add a new syllograph to the inventory, click Add. The Update Syllograph Inventory dialog box reappears with empty5.
fields. Enter the desired syllograph and its appropriate categories. Click Save. Then click OK. The Update Syllograph
Inventory dialog box reappears.
Click Previous to display the previous syllograph in the inventory. Click Next to display the next syllograph in the list.6.
To find a given syllograph, in the Find text box, type the syllograph. Then click Find. The syllograph is displayed.  If the7.
application cannot find the syllograph, it means the syllograph is not in the inventory and will need to be added.
If you want to change the categories of the displayed syllograph, just make the appropriate changes and then click Save.8.
When done, click Exit.9.

For more information on the grapheme inventory, refer to the help facility.



Verifying the Grapheme Inventory

Next you will want to verify that Grapheme Inventory has been correctly setup.  First you should display the Grapheme Inventory
to verify that all the graphemes are there

On the View menu, click Grapheme Inventory. On the Format Menu, set the Word Wrap.  All of the syllographs from the
current grapheme inventory, are displayed in the active document.

You should also display the syllograph chart to verify the syllographs have the correct categories.

On Search menu, click Syllograph Chart Search.  The Syllograph Chart is displayed in the currently active document.

If you need to make any changes to the grapheme inventory, you should do so and then go through the verification process again. 
This can be an iterant process.

Importing Word List

Now you are ready to import the wordlist.  The word list file needs to be a Standard Format Marker (SFM) file or a Lift file.  It
must be a UTF-8 file as well.  If it is a SFM, verify that you have the correct field codes in the option settings to match the word
list.  If it is a LIFT file, make sure you have the correct language codes in the option settings to match the word list.

To import a wordlist file, do one of the following.1.

On the Tools menu, point to Word List, and point to Import and click Standard Format Lexicon. This will open a Standard
Format Marker (SFM) file.
On the Tools menu, point to Word List, and point to Import and click LIFT Lexicon. This will open a Lexicon Interchange
Format (LIFT) file.

The Open dialog box appears.

Navigate to and select the desired file, and then click Open.  The wordlist is loaded.1.
Click OK after wordlist has been imported.  Now to verify the word list has been imported properly, display a listing of the2.
current wordlist.

On the View menu, click Word List.  A listing of the current wordlist, along with a count, is displayed in the active
document. Information about each word is displayed with the word.

You also might want to check to verify that you do not have any unwanted characters in the word list. If so, you may need to clean
up the word list.

On the Tools menu, point to Word List, and then click Check against Grapheme Inventory.  PrimerPro will display a list of
any characters which are in the word list, but are not in grapheme inventory.

Importing the Text Data

Now you are ready to import the text data.  The text data must be a UTF-8 plain text.

On the Tools menu, point to Text Data, and then click Import.  The Open dialog box appears.1.
Navigate to and select the desired file, and then click Open.  The text data is loaded.2.
Click OK after text data has been imported.3.

If you have several text files, you need to merge them.

On the Tools menu, point to Text Data, and then click Merge.  The Open dialog box appears.1.
Navigate to and select the desired file, and then click Open.  The selected text data is appended to the current text data.2.
Click OK after text data has been merged with current text data.3.

After merging all the files, you need to save the new file you’ve created.

On the Tools menu, point to Text Data, and then click Export.  The Save As dialog box appears.1.
Navigate to the desired folder. In the File name text box, enter the desired file name for the new text data file, and then2.
click Save.  The current text data is saved to the selected file as a UTF-8 plain text file. This becomes the new current text
data.
Click OK after exporting.3.

Now to verify the text data has been imported properly, display a listing of the current text data.

On the View menu, click Text Data.  The text of the current text data, along with the paragraph count, the sentence count
and the word count, is displayed in the currently active document.



You also might want to check to verify that you do not have any unwanted characters in the text data. If so, you may need to clean
up the text data.

On the Tools menu, point to Text Data, and then click Check against Grapheme Inventory.  PrimerPro will display a list of
any characters which are in the text data, but are not in grapheme inventory.

Generating Syllabic Chart

The syllograph chart will show you all the syllographs to be taught.  This is useful for verifying you have all the syllographs
required to be taught.

To generate a syllograph chart, do the following.1.
On the Search menu, click Syllograph Chart Search.  The syllograph chart  is displayed in the active document.

To save the chart as a RTF file, do one of the following.2.
Press Ctrl+S.
On the File menu, click Save.
On the File menu, click Save As. The Save As dialog box appears. In the Save in list, navigate to the appropriate
folder. In the File name box, type the appropriate name, for example, VowelReport.rtf. Click Save.

Then you can print the chart or display it in a word processor to review it.  If you need to make changes, you will need to update
the grapheme inventory.

Determining Grapheme Taught Order

To determine the suggested Grapheme Taught Order,  you will need to run the Teaching Order search. You can also run the
Frequency Count search to inform the process.   Using these searches giving priority to the Teaching Order search, you can
determine the teaching order.

To generate a recommended teaching order, do the following.1.
On the Search menu,  point to Text Data, and click Teaching Order Search.  The Teaching Order Search dialog box
appears.  Reset Consonant and set Syllograph.  Select the desired catergory. Then click OK.  The search results are
displayed in the active document.

To generate a frequency count, do the following.2.
On the Search menu,  point to Text Data, and click Frequency Count Search.  The Frequency Count Search dialog
box appears.  If you want to see percentages with the count, set Display Percentage.  Then click OK.  The search
results are displayed in the active document.

To save the results as a RTF file, do one of the following.3.
Press Ctrl+S.
On the File menu, click Save.
On the File menu, click Save As. The Save As dialog box appears. In the Save in list, navigate to the appropriate
folder. In the File name box, type the appropriate name, for example, PrimerProgressionReport.rtf. Click
Save.  Then you can print the results or display it in a word processor.

Using these results, draft a teaching order.4.
Enter the teaching order onto the Primer Progression Chart.5.

Setup Conclusion

Now you have completed the setup.  To exit PrimerPro, do the following.

On the File menu, click Exit.

PrimerPro will remember the last current project and all its option settings.  The next time you start PrimerPro, the project will be
selected with all its options setting.  The associated word list file and text date file will be automatically imported.

 

 [1] https://lingtran.net/tiki-download_file.php?fileId=1636
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