
PrimerPro Primer Making
PrimerPro Primer Making Tutorial
PrimerPro is a computer application designed to assist literacy personnel in the creation of scientifically
designed primers, by capitalizing on the grammatical and phonological properties of these languages. The
program and accompanying instructions help primer developers determine the teaching order of
consonants, find buildable words for stories, check stories for untaught letters, and perform other key
tasks in producing reading primers.

This tutorial is a step by step procedure on how to use PrimerPro to assist you in producing a primer.  The
tutorial will walk through one scenario for using PrimerPro for producing a primer.  Please note that there
are other scenarios for using PrimerPro that are just as valid.  Once you use this tutorial for learning
PrimerPro, you should feel comfortable on how to use PrimerPro in your situation.  This tutorial assumes
that PrimerPro has already been setup on your computer.  See PrimerPro Setup Tutorial for details.

You will also need a 4,000+ word list, in a Standard Format File or LIFT file, in UTF-8 format.  This can be
created using either Toolbox, FieldWorks or WeSay.  You will also need a 4000+ words of edited text (so
the spelling is correct!) in plain text files in UTF-8 format.

A primer usually consists of two kinds of lessons. The first kind is a teaching lesson where you are
teaching one or more graphemes in the lesson. The second kind is called a review lesson where you are
not teaching any new grapheme, but instead you are focus on reviewing what has been taught already. 
These lessons are also used to teach some grammar aspect of the language.

Starting PrimerPro
You can start the program by double-clicking on the PrimerPro icon on the desktop.

Select Project
The first thing you want to do is select your project that you created in the PrimerPro Setup Tutorial.
 Below are the steps.

On the File menu, click Select Project.1.

The Select Project dialog box appears.

In the list box, select your project and click OK.1.

Your project is loaded into the application.

Click OK..1.

Your project is now the current, or active, project. 

Importing Data
On the status bar, the current word list filename is displayed.  If it is not the correct word list file or it is
not specified, then you will need to import the correct word list file.  To import the correct word list, do
the following.

To import the word list file, do one of the following.1.

On the Tools menu, point to Word List, and point to Import and click Standard Format Lexicon. This
will open a Standard Format Marker (SFM) file.
On the Tools menu, point to Word List, and point to Import and click LIFT Lexicon. This will open a
Lexicon Interchange Format (LIFT) file.

The Open dialog box appears.



Navigate to and select the desired file, and then click Open.1.

The word list is imported into the application.

Click OK after word list has been imported.1.

On the status bar, the current text data filename is displayed.  If it is not the correct text data file or it is
not specified, then you will need to import the correct text data.  To import the correct text data, do the
following.

On the Tools menu, point to Text Data, and then click Import.1.

The Open dialog box appears.

Navigate to and select the desired file, and then click Open.1.

The text data is loaded.

Click OK after text data has been imported.1.

Sight Words
You will need to add all the sight words that were taught in the pre-primer. To update the list of current
sight words, do the following:

On the Tools menu, point to Sight Words, and then click Update Sight Words.1.

The Update Sight Words dialog box appears. The list of sight words is displayed.  It should be empty at
this point.

In the Edit the list box, add the list of sight words, verifying that the box has one sight word per line.1.
When done, click OK.2.

First Lesson
Now you are ready to start making your first lesson.  Below are the steps you will do to accomplish this.

Add the first lesson’s grapheme(s) to the graphemes taught list by updating the graphemes taught1.
list.  To update the list of current graphemes taught, do the following.

On the Tools menu, point to Graphemes Taught, and then click Update Graphemes Taught.

The Update Graphemes Taught dialog box appears. Note that the graphemes taught list should be empty.

In the Edit the list box, add the grapheme(s) for the first lesson, verifying that the box has one
grapheme per line.
When done, click OK.

Now you want to find words to use in a story for the first lesson.  You can find these words using1.
the Buildable Word Search for Word List using only the graphemes in grapheme taught list. To
run the Buildable Word Search, do the following:

On Search menu, point to Word List, and then click Buildable Words Search.

The Buildable Words Search dialog box appears.

In the Graphemes box, note that the initial graphemes displayed are those from the graphemes taught list.

Click OK.

The results are displayed at the insertion point in the current active document.  A list of buildable words
from the current word list are displayed, Then print or save to a file the displayed word list, noting the



useful words for first lesson story.

To print the displayed word list, do the following.  On the File menu, click Print. The Print dialog box
appears.  Select the printer and click OK.

To save to a file the displayed word list, do the following. On the File menu, click Save As. The Save As
dialog box appears. Navigate to the desired folder and enter the desired file name, and then click Save.

If you do not find enough words through the Buildable Word Search for Word List, you can use the1.
Buildable Word Search for text Data to find more potential words.  To run the Buildable Word Search,
do the following

On the Search menu, point to Text Data, and then click Buildable Word Search.

The Buildable Word Search dialog box appears.

In the Graphemes box, note that the initial graphemes displayed are those from the graphemes taught list.

Select No Duplicates.
Click OK.

The results appear at the insertion point in the active document.  A list of buildable words from the
current text data is displayed.   Then print or save to a file the displayed list of words, noting the useful
words for first lesson’s story.

If you have no nice, pictureable word in your list, and you need one for a keyword, you can also use1.
the Grapheme Search on the current word list restricting the search to nouns. Do the following.

On Search menu, point to Word List, and then click Grapheme Search.

The Grapheme Search dialog box appears.

In the Grapheme to find box, type the desired grapheme, the grapheme that is being taught.
Click Search Options.

The Search Options Filter dialog box appears.

In the Part of speech box, select Noun, and then click OK.

The Grapheme Search dialog box reappears.

Click OK.

The results appear at the insertion point in the current active document.  A list of potential keywords from
the current word list is displayed.

Write a story using buildable words and enter it into a text editor. See Story Checklist1 document for1.
guidelines. Save the story as a UTF-8 plain text.
Make words drills for the primer, after the story has been written. Then you know which words should2.
be practiced in advance of the story.

Make syllable drills for the primer, being sure to give people practice with the syllables used in the built
words.

Then run a Untaught Residue Search on the story, displaying in paragraph format and ignoring sight1.
words. The story should be displayed without any highlighting. Highlighting indicates untaught
residue.  To run the Untaught Residue Search, do the following.
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On Search menu, point to Text Data, and then click Untaught Residue Search.

The Untaught Residue Search dialog box appears.

Select Browse. The Open dialog box appears. Navigate to and select the desired story file. Then click
OK.

The Untaught Residue Search dialog box reappears.

Select Display in Paragraph Format. The results will be displayed in paragraph format.
Select Ignore Sight Words. This means any sight word in the current text data will not be flagged as a
untaught word.
Click OK.

The results appear at the insertion point in the active document. The story file is displayed with the
graphemes that have not been taught yet highlighted. After the text data is displayed, the count of the
untaught words is displayed.

If there are any untaught words, you will need to redo the story, and then check it again.

Create an “All Stories” text file using a text editor in a location of your choosing.  Add the story for1.
the first lesson to this file.
Take all data you have collected for the lesson and use it to make the primer's first lesson using a2.
publishing tool (e.g. MS Publisher).

Subsequent Lessons
Now you are ready to start making your next lesson.  Below are the steps you will do to accomplish this.

Add the lesson’s grapheme(s) to the graphemes taught list by updating the graphemes taught list.  To1.
update the list of current graphemes taught, do the following.

On the Tools menu, point to Graphemes Taught, and then click Update Graphemes Taught.

The Update Graphemes Taught dialog box appears.

In the Edit the list box, add the grapheme(s) for the lesson to the end of the list, verifying that the box has
one grapheme per line.

When done, click OK.
Check to verify the grapheme taught list contains only valid graphemes.1.

On the Tools menu, point to Graphemes Taught, and then click Check against Grapheme Inventory.

The results should indicate none.

Now you want to find words to use in a story for the lesson.  You can find these words using the1.
Buildable Word Search for Word List using only the graphemes in grapheme taught list. To run the
Buildable Word Search, do the following:

On Search menu, point to Word List, and then click Buildable Words Search.

The Buildable Words Search dialog box appears.

In the Graphemes box, note that the initial graphemes displayed are those from the graphemes taught list.

Click OK.

The results are displayed at the insertion point in the current active document.  A list of buildable words
from the current word list are displayed, Then print or save to a file the displayed word list, noting the



useful words for the lesson’s story.

As the graphemes taught list increases, the buildable word list will also increase.  When the buildable1.
word list gets too long to manage, you may want to get a list of only the new buildable words
generated by the graphemes taught in the lesson using the Grapheme Search for the word list. To run
the Grapheme Search, do the following.

On Search menu, point to Word List, and then click Grapheme Search.

The Grapheme Search dialog box appears.

In the Grapheme to find box, type the grapheme being taught by this lesson.
Select Restrict to Graphemes Taught.  This will display those words that contain only the graphemes
in the grapheme taught list.
Click OK.

The results appear at the insertion point in the current active document. It displays a subset of the word
list that contains the desired grapheme.

Note that if a word contains any grapheme that is not yet in the grapheme taught list, the word will not be
displayed, even if it contains the grapheme being taught.

If you do not find enough words through the Buildable Word Search for word list, you can use the1.
Buildable Word Search for text data on the current text data to find more potential words.  To run the
Buildable Word Search, do the following

On the Search menu, point to Text Data, and then click Buildable Word Search.

The Buildable Word Search dialog box appears.

In the Graphemes box, note that the initial graphemes displayed are those from the graphemes taught list.

Select No Duplicates.
Click OK.

The results appear at the insertion point in the active document.  A list of buildable words from the
current text data are displayed.   Then print or save to a file the displayed list of words, noting the useful
words for the lesson’s story.

As the graphemes taught list increases, the buildable word list will also increase.  When the buidable1.
word list gets too long to manage, you may want to get a list of only the new buildable words
generated by the graphemes taught in the lesson using the Grapheme Search for the text data. To run
the Grapheme Search, do the following.

On Search menu, point to Text Data, and then click Grapheme Search.

The Grapheme Search dialog box appears.

In the Grapheme to find box, type the grapheme being taught by this lesson.
Select Restrict to Graphemes Taught. This will display only those words in the text data that contain
only the graphemes in the grapheme taught list.
Select No Duplicates.
Click OK.

The results appear at the insertion point in the active document. It displays a list of words from the
current text data that contains the desired grapheme.

Note that if a word contains any grapheme that is not yet in the grapheme taught list, the word will not be



displayed, even if it contains the grapheme being taught.

If you find interesting pictureable words, take note of them for use as keywords. . If there are no built1.
words which are pictureable, you'll need to use Grapheme Search for the word list looking only for
nouns containing the lesson's grapheme.
Find usable phrases for the story by using the Usable Phrase Search containing only the graphemes2.
in the grapheme taught list. Initially you probably will want to use a value of two for the minimal
number of words in a phrase. Print the list, noting useful phrases for this lesson's story. To run the
Usable Phrase Search, do the following.

On Search menu, point to Text Data, and then click Usable Phrases Search.

The Usable Phrases Search dialog box appears.

In the Minimal number of words in a phrase box, enter the appropriate number This restricts a phrase
to a minimal number of words.
In the Highlight phrases with this grapheme box, enter the grapheme being taught. When the list of
phrases is displayed, if the grapheme being taught is contained in the phrase, then the phrase is
highlighted.
Click OK.

The results appear at the insertion point in the active document. A list of potential phrases from the
current text data for the story is displayed. Print or save to a file the phrase list.

If the phrase list becomes too long to manage, increase the number in the Minimal number of words in a
phrase box. As you work through the graphemes taught list, you probably will want to increase the
minimal number of words in a phrase, to keep the list to a manageable size.

Write a story using buildable words and any usable phrases which will help your story be natural1.
sounding and give readers practice. For the first two weeks, restrict story size to 12 words. Later
lessons should gradually increase in size, up to 25 or 30 words by the end of the primer.
Make words drills for the primer, after the story has been written. Then you know which words should2.
be practiced in advance of the story.

Make syllable drills for the primer, being sure to give people practice with the syllables used in the built
words.

Enter the story in a word processor. See Story Checklist document for guidelines. Save the story as a1.
UTF-8 plain text. Then run a Untaught Residue Search on the story, displaying in paragraph format
and ignoring sight words. The story should be displayed without any highlighting. Highlighting
indicates untaught residue.  To run the Untaught Residue Search, do the following.

On Search menu, point to Text Data, and then click Untaught Residue Search.

The Untaught Residue Search dialog box appears.

Select Browse. The Open dialog box appears. Navigate to and select the desired story file. Then click
OK.

The Untaught Residue Search dialog box reappears.

Select Display in Paragraph Format. The results will be displayed in paragraph format.
Select Ignore Sight Words. This means any sight word in the current text data will not be flagged as a
untaught word.
Click OK.

The results appear at the insertion point in the active document. The story file is displayed with the



graphemes that have not been taught yet highlighted. After the text data is displayed, the count of the
untaught words is displayed.

If there are any untaught words, you will need to redo the story, and then check it again.

If you want to verify which sight words you are using in the story, run the Sight Word Search. To run1.
the Sight Word Search, do the following.

On the Search menu, point to Text Data, and then click Sight Word Search.

The Sight Word Search dialog box appears.

Click the Browse button. In the Open dialog box, navigate to and select the story file, and then click
OK.
Click Check All to select all the sight words.
Select Display in Paragraph Format to be displayed in paragraph format.
Click OK.

The results appear at the insertion point in the active document. The text data is displayed with all the
sight words highlighted.

To be sure you’re using enough new words, or not too many, you can check the story to see how many1.
new words are in it.

On the Search menu, point to Text Data, and then click New Word Search.

The New Word Search dialog box appears.

Select Browse for the Base file. The Open dialog box appears.  Navigate to the “All Stories” file.  Then
click OK.
Select Browse for the Story file. The Open dialog box appears.  Navigate to the story file.  Then click
OK.
Select Display in Paragraph Format. The results will be displayed in paragraph format.
Click OK.

The story is displayed with the new words (words that have not been used in a previous story)
highlighted.  If there are too many new words, you may need to rewrite the story.

Add the story for the lesson to the “All Stories” file.

Take all data you have collected for the lesson and use it to make the primer's lesson using a1.
publishing tool (e.g. MS Publisher).

You continue to repeat the Subsequent Lesson section for each teaching lesson of the primer.

Review Lessons
Every fifth lesson should be a review lesson. To create a review lesson, consider the following:

See Writing a Review Lesson2 document for details on review lesson design.1.
Refer to Primer Progression Chart, looking to identify built words and sight words which should be2.
practiced. List them and design an exercise which gives the reader practice using those words. The
exercise should differ somehow from the stories used previously in the week. If it is a story, the plot
and characters should be different from the usual ones. See Writing a Review Lesson document for
other ideas.
Choose a simple illustration to accompany the review activity.3.
Design a short functor lesson. It should consists of two activities. Put your functor activities into the4.
template provided.

https://lingtran.net/2


Mark the times the built and sight words are used, including times they are used in the functor5.
exercise, on the Primer Progression Chart.
Record any functor taught in the blank spot for the review lesson in the Primer Progression Chart.6.
For example, you would write “assoc. markers ya, wa” in the blank.
Design the “creative writing” syllable boxes. The first review lesson should only contain 12 syllable7.
boxes. Later review lessons can contain an additional row. List built words used frequently in the
previous lessons. From this list, choose syllables which occur often in the word list. Fill them into
boxes, and see how many words (either from the stories or new ones) can be made from different
syllable boxes. Change as needed. See Writing a Review Lesson document for an example.

Setup Conclusion
Now you have completed the primer making tutorial.  To exit PrimerPro, do the following.

On the File menu, click Exit.

PrimerPro will remember the last current project and all its option settings.  The next time you start
PrimerPro, the project will be selected with all its options setting.  The associated word list file and text
date file will be automatically imported.

 


	PrimerPro Primer Making
	PrimerPro Primer Making Tutorial
	Starting PrimerPro
	Select Project
	Importing Data
	Sight Words
	First Lesson
	Subsequent Lessons
	Review Lessons
	Setup Conclusion



